2

In Firefox, I have a master password setup for my passwords. I also sync my passwords (and bookmarks, extensions and settings) using Firefox sync.

The annoying thing is that when I start up Firefox, it will always ask for my master password after a few seconds. So when I start up Firefox and type a web address or search query, I get interrupted by the password dialog popping up while I'm typing. I want to get around this because it is annoying me so much.

Questions:

  1. Can I make Firefox sync manually?
  2. Alternatively can I make Firefox sync only when I have to enter a password somewhere?
  3. Alternatively can I enter a delay value somewhere in about:config between starting up Firefox and running Firefox sync?
  • Sorry, can't answer this one. But I will say that I don't use sync to manage passwords. I use LastPass which is a much better tool that works across all major browsers. I don't have your issues when using LastPass. – Julian Knight Jan 26 '14 at 18:32
  • @Blaise Sync timers could be helpful?? Please note that I haven't tried these. To filter these prefs in bulk use sync*sch and/or sync*int in about:config. – vWil Jan 27 '14 at 15:03
  • @vWil, I tried that before, increasing all sync timers to three hours, but that didn't work. The descriptions also suggest they change the interval between syncing, not delaying the initial sync after start-up. – Blaise Jan 30 '14 at 11:54
  • @JulianKnight, LastPass does not sync extensions and settings and has an obtrusive interface. – Blaise Jan 30 '14 at 11:56
  • Hi Blaise, I know it doesn't sync those things which is why I didn't give it as an answer only a comment. Personally, I've had great problems with sync of FF extensions across platforms and across personal/work machines so I tend not to. I only really want to sync bookmarks since LastPass sync's my passwords and more across ALL browsers and ALL platforms. The interface is a matter of choice. The latest FF interface is pretty good actually. – Julian Knight Jan 30 '14 at 16:54
2

I asked the same question on Mozilla Support and got very useful answers. Answer that worked for me:

  • In about:config, create or modify Boolean services.sync.autoconnect and set it to false.

This may work in a future version of Firefox: Create or modify integer services.sync.autoconnectDelay and set it to a delay in seconds. Both settings did not exist for me yet in Firefox 28 beta.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.