0

So I use remote desktop a fair amount of the time at work, and I'm running into the following issue:

Sometimes, when switching back and forth between my remote and local session (remote session is typically up on second monitor), after switching focus to the local machine, it will behave as if one of the modifier keys is being held down (typically either Win or Ctrl) (so for example trying to type a p will bring up the Win+P projector connection menu).

Hitting whichever modifier key Windows thinks is being pressed several times is enough to reset it and make typing life normal, but I'm wondering if there's any solution to make this issue go away.

  • this is a problem with a lot of remote access software. Not just RDP. So I believe it is something hard to prevent since so many software suffers with it :-\ – Vitas Jan 27 '14 at 20:57
0

Well after playing around a bit more, I found a partial workaround.

First off, what was causing the problem:

  1. Start in a locally-focused window
  2. Use Win+<num> to bring focus to remote desktop session
  3. Click on an item in the taskbar to bring focus back to local session
  4. Win key is now stuck down

A workaround, which fixes the problem by disabling Win combinations, is to, when connecting, go to Options>Local Resources>Keyboard, and change "Apply Windows key combinations" to "On this computer".

A fix

This is an obnoxious enough workaround that I really don't want to mark it as the best answer. Someone please find a better way to fix this :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.