0

I'm having troubles running an XP program (Robcad 7.5.1) under Windows 7. The program calls an executable called colsetup.exe and fails: log shows it needs admin right, but it does not (I think it's because it has "setup" into its name). colsetup.exe icon is shown with the shield, and even removing the check from "Run This Program As An Administrator" does not work.

If I start Robcad with admin privileges, it does not start because it cannot get the license from FlexLM (maybe the user name is different?).

Can anyone help me solve one of the two problems?

The problem can be solved by disabling installer detection in security policies, but I'd like to not have to touch them (current, temporary, computer is on its own, the next one should be in a domain and this setting could be locked by network administrators).

Thank you,

Ignazio

  • According to this source, colsetup.exe is part of Robcad. It's located in %SystemDiskRoot%\Robcad\bin. It might be best to ensure Robcad is installed with a user who has administrative access. I have no experience with the program. – iamwpj Jan 27 '14 at 21:23
  • iamwpj, it was. Kevin, thanks to your link I discovered "installer detection" can be disabled. Doing so, it works. Now, there is something I can do to disable it just for the problematic file? – neclepsio Jan 28 '14 at 8:25
0

I solved by adding a colsetup.exe.manifest file:

<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<assembly xmlns="urn:schemas-microsoft-com:asm.v1" manifestVersion="1.0">
   <trustInfo xmlns="urn:schemas-microsoft-com:asm.v3">
      <security>
         <requestedPrivileges>
            <requestedExecutionLevel
               level="asInvoker"
               uiAccess="False"/>
         </requestedPrivileges>
      </security>
   </trustInfo>
</assembly>
| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.