0

I am trying to install a dual boot with Ubuntu on my Mac Version 10.8.5.

I first installed Refit but I forgot to reboot my computer so that Refit get properly installed. My mistake was to boot Ubuntu directly from a usb key and install it. I had no problem for the installation of Ubuntu but it crashed when I tried to download a software on Ubuntu. When I tried to reboot on MacOS the system would not boot even though it recognized the kernel. I had to shut down my computer, plug a Windows keyboard and press the alt key on this Windows keyboard when restarting my computer: then I could reboot on MacOS and launch the Refit script enable-always.sh in the /efi/refit directory. After, I tried to reboot on Ubuntu but it will not boot back. So I decided to clean the Ubuntu partition and start again.

I booted on MacOS. I went to diskutility and find out there were 3 partitions in my disk instead of 2 because of the Linux swap. I tried to remove the Linux and LinuxSwap partitions to only keep the Mac one but the LinuxSwap partition would not remove itself: it was just unmounted but still present and occupying 5Go. I had to download gparted and boot on it using a usb key. Accessing gparted, I deleted the LinuxSwap partition.

Then I tried to boot on Ubuntu using a usb disk.

On the Refit interface, I have now several Linux booting options from where to boot from. The first Linux booting option is using grub and I think is kept from my first installation of Ubuntu but when launched does not work because I have removed the partitions.

My first issue is there : I dont know how to remove this booting option. I am hesitating to install Refind (which is a better option than Refit since it is under developement while Refit isnt) to override Refit and maybe solve the problem but I am not even sure this will solve the problem. I have already tried to reinstall Refit from a new package to override the old one but it kept this booting option. I have seen this post on ubuntu forum, http://ubuntuforums.org/showthread.php?t=811240, but it seems that the commands are to be done from ubuntu and not mac and I am not sure it will not do more harm and make my computer unbootable (even though I have a time machine backup I don't have the Mac CD where I am).

The other booting options (other than the MacOS boot or the fake Linux boot) originate from my usb key and are the following: I can boot either from bootx or grubx. I didn't know the difference and tried to install ubuntu using either one of them but I had the same problem. After the window requiring 4.5 Go of disk, Internet connection and something else (that I have all), when I click continue it keeps loading without going to the next step. I don't know where the problem comes from: I don't know if it is because I'm booting from the usb disk but I didn't have any problem to boot the first time I installed Ubuntu (first paragraph of this post). Is there any log file where I can check what exactly the installation is doing and why it is not going to the next step of the installation?

Thank you for the help.

0

1 Answer 1

0

As far as i know, you can ignore the "fake linux boot" in Refit. Refit detects a boot loader somewhere on your hard drive. It will be overwritten by a new Ubuntu install.

For the problem of your Ubuntu USB boot disk, i would try to recreate it from scratch to make sure all files are OK, or to use the check disk option at grub screen.

the log file that may contain informations on your problem is /var/log/syslog (probably accessible from shell with ctrl + alt + f1) and with this command:

tail -n 100 -f /var/log/syslog

With the informations you've given, this is as far as i can help.

EDIT: Refit is now obsolete and has been replaced by rEFInd.

2
  • I reinstall ubuntu on my usb disk and boot on it again.It worked.But when I go back to the diskutility on mac I have 4 partitions and not 3. Macintosh my main disk ; disk0s3 1Mo but the most awkward is the type of partition: 21686148-6449-6E6F-744E-656564454649 ; disk0s4 46Go with format: MS-DOS (FAT) ; disk0s5 4Go Linux Swap. I guess that most probably the disk0s3 is due to my first installation of Ubuntu. Do you know a way to remove it?
    – polandspr
    Jan 28, 2014 at 19:24
  • i'm not sure, but the 1MB partition is probably internal to MacOS X (recovery) ? (ps Mo=MB in english)
    – Biapy
    Feb 2, 2014 at 10:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .