I have a wired network using the workgroup of PAPERTECH with the following machines:

  • Windows XP (hostname: WinXP)
  • Ubuntu 12.10 (hostname: WebServer) - via Samba
  • Mac OS X 10.9 (hostname: MacMini)

The problem is that the Mac cannot resolve the hostname for the Ubuntu web server as it cannot ping it.

Ping Summary:

  • From the Windows machine I can ping MacMini and WebServer.

  • From the Ubuntu machine I can ping WinXP.PAPERTECH.local but cannot ping MacMini.PAPERTECH.local.

  • From the Mac machine I can ping WinXP.PAPERTECH.local but cannot ping WebServer.PAPERTECH.local.

Mac Setup

I've set the workgroup using the Network settings under: System Preferences > Network > Ethernet (Advanced ...) > WINS. I've also enabled 'Share files and folders using SMB' under: System Preferences > Sharing > File Sharing.

Despite the above settings the Mac is still unable to ping or connect to the server using the hostname: WebServer (NOTE: it is able to ping the IP address it resolves to).

Any other ideas?


Did you remember to add the line

 netbios name = your_pc_name

in the file /etc/samba/smb.conf, and to restart the services nmbd and smbd and/or to reboot?

  • 1
    I tried adding this below [global] settings and restarted both nmbd and smbd but it didn't seem to make a difference. I then also tried a reboot after making the changes but it didn't seem to make a difference either. – paperclip Jan 28 '14 at 15:27

If you can ping by IP, then the issue is a DNS resolution issue.

There are two ways to resolve your issue if you want to use names.

Set up a DNS server to be used by all your machines.

Update your hosts files on the Linux and Mac boxes. This is located in /etc/hosts

  • The hostname's mentioned above are the FQDN's on the network so I would have thought that I don't need to edit the /etc/hosts. – paperclip Jan 28 '14 at 15:24
  • FQDN or not, if you cannot resolve a name to an IP you will not be able to connect. Did you try @MariusMatutiae s answer? – Deesbek Jan 28 '14 at 16:29
  • Yep, tried @MariusMatutiae's suggestion but it didn't appear to make a difference. I guess I'm expecting that I should be able to resolve the FQDN on both Windows and Mac as they are both part of the same network and workgroup. – paperclip Jan 28 '14 at 16:35
  • 1
    For FQDN to work you need to have a DNS server set up as I specified. Or you have to configure your DHCP server to provide the full DNS info. – Deesbek Jan 28 '14 at 16:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.