1

I am trying to run an Ubuntu 13.10 VirtualBox. I went through all the settings just fine. When I go to start the VirtualBox for the first time, I select my Disc Image File and it boots fine. If I save the state of machine instead of shutting down, I can restart the VM fine.

When I do a shutdown, and then try to start the VM again, it says

no bootable medium found

Where do I go to specify these medium? I've tried hitting F12 on start up, and it gives me options

VirtualBox temporary boot device selection
Detected Hard Disks:

AHCI controller: 
    1) Hard Disk

Other boot devices: 
f) Floppy
c) CD-ROM
l) LAN 

b) Continue booting

What do I choose, or what do I do?

1

You appear to be running a live system. This will NOT save your data upon a reboot. This may or may not be what you want.

On a shutdown, Ubuntu sends a signal to 'eject' the disc. Virtualbox obeys and removes the file form the virtual drive. You can add the disc again in the virtual machine's settings.But to get around this problem you have 2 methods:

  1. Install Ubuntu. Run the installer, complete the process, reboot, the disc will be gone and you will have a working system. This will save your data and will work through reboots/shutdowns etc.

  2. Go into Settings > Storage and click on the disc and check the box to the right marked Live CD/DVD. This will make virtualbox not eject the disc even if told to by the Operating System.

Hope I have helped ;) (Don't forget to click the tick to accept an answer)

0

You seem to be starting it from a LiveCD. I don't assume that Virtualbox will retain whatever CD you had in the 'virtual drive' if you do a reboot.

To get around this, you might consider installing Ubuntu to a virtual disk once the live cd starts.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for?Browse other questions tagged or ask your own question.