34

I have to restart my intellij every like 20 minutes whenever I hit multiple times ctrl+tab. It looks like clicking this multiple time on my ubuntu 13.10 + intellij 13.01 makes my intellij stuck. on intellij 12 same OS everything is just fine. anyway to work around this?

  • Same issue here, so annoying! – Remi Mélisson Feb 13 '14 at 11:45
  • 3
    IntelliJ 14.1 + Ubuntu 14.10 still affected, although ctrl+click works – Michal Kováč Feb 6 '15 at 15:02
57
+350

workaround try this when it happens:

ibus-daemon -rd

http://youtrack.jetbrains.com/issue/IDEA-115661

http://youtrack.jetbrains.com/issue/IDEA-78860

| improve this answer | |
  • 10
    The answer saved many hours of mine. hence awarding a bounty (in 24 hours) – Jatin Jul 17 '14 at 11:40
  • 1
    After using 'ibus-daemon -rd' only English works in IDEA and other languages stops working (for my case Persian) – Mohsen Kashi Nov 5 '14 at 7:47
  • 1
    @MohsenKashi Yes, you should run setxkbmap after that to set languages correctly. – Dmitry Ginzburg Jan 27 '15 at 11:16
3

Restarting ibus-deamon may cause issues with other applications¹ or even crash IntelliJ, according to IDEA-78860. However it also suggests there are 2 alternate solutions:

  • Disabling IBUS support for idea. This is done with an empty XMODIFIERS environment variable when starting IntelliJ. For example, add this at the beginning of idea.sh and restart IntelliJ:

    # workaround for https://youtrack.jetbrains.com/issue/IDEA-78860
    export XMODIFIERS=
    
  • Force IBUS to keep the order of events by setting IBUS_ENABLE_SYNC_MODE=1 for ibus-daemon². In my case I implemented it by adding the following to my ~/.xsessionrc (create the file if it does not exist) and restart my session:

    # workaround for https://youtrack.jetbrains.com/issue/IDEA-78860
    export IBUS_ENABLE_SYNC_MODE=1
    

(I actually did both so I don't know which one fixes it for me)

If this works for you, this has the advantage of fixing the problem once and for all, and you shouldn't have to restart ibus-daemon any more.

The only inconvenient is that you need to restart IntelliJ or even your whole session to apply it the first time.

¹ In my case dead keys didn't work any more afterwards in some applications like Skype.
² Apparently IBUS should have the sync mode enabled by default in a future release, see issue 1697 and the corresponding commit.

| improve this answer | |
0

In my case, it was something different. I got this weird behaviour after I entered my licence credentials to Idea. I suppose it created a new Jet Brains user's account for me with an ability to sync IDE settings enabled by default. My suggestion that it has overridden my setting (including keyboard bindings) with some default ones created by Jet Brains.

Fortunately, I had previously set up my Settings Repository on Github. I rolled back to my old settings pressing File -> Settings Repository -> Override Local.

The issue was on macOS in Database editor.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.