24

My NVIDIA Control Panel seem to have a lack of settings other than the 3D Settings;

enter image description here

I searched around a bit and found some similar problems on other websites which seemed to either have solutions that didn't work, or no replies at all.

I have a nVidia Geforce 710m and I'm on Windows 8.1 however the problem also occurred before 8.1 on 8, I re-updated a few minutes ago to the latest drivers for my GPU and OS (332.21) and the problem is still there.

Any help would be much appreciated.

  • It would save time if you listed the solutions you already tried. – harrymc Feb 1 '14 at 13:32
  • 2
    Also, what is your computer and do you have an onboard integrated Intel graphics processor in addition to the Geforce? – harrymc Feb 1 '14 at 18:04
  • it's suggested to install older drivers, you can find them on the nvidia.com website in archive, this will probably solve your issue, if it does, i can make it an answer. – Sickest Feb 1 '14 at 19:30
  • @harrymc Mainly just uninstall and reinstall drivers, update drivers. And yes I do have Intel integrated graphics in addition to Geforce. – AlphaDelta Feb 2 '14 at 3:22
17
+50

The Intel integrated graphics adapter in your computer is most probably the source of the problem.

The thread Force 4:3 ratio / pillarbox with 540M explains it :

Your "problem" is not a problem at all but its the nature of your machine. You have an "Optimus" system which means you have an intel graphics processor and an Nvidia.

You do not have the option in the Nvidia control panel since the intel driver / graphics processor is the default processor to handle video scaling. Hence no option in the Nvidia control panel.

In the nvidia control panel you should only have 3D and video options. The "display" options for which the scaling is located in the nvidia control panel is not needed since the intel driver handles that part.

So yeah, in a nutshell there's no problem.

Another entry in the same thread says :

Not having experience with Optimus it was just a guess, as it works that way on my PC with HD4000 and AMD gpu.

When the integrated is selected as default in BIOS the AMD control panel is not fully functional (Don't have integrated on the Nvidia machine). I find it more difficult to get good results with the HD4000 re - aspect ratio.

If your BIOS has an option to define the nVidia Geforce as default, this might fix the problem, but might place more demand on your battery.


The thread Stereoscopic 3D missing in nvidia control panel has a simpler solution, which is to ensure during the Nvidia driver installation that all its components are marked for installation, even the ones that are unchecked by default since they are currently handled by the on-board Intel adapter.

Try to reinstall the Nvidia driver to see if this is also true in your case.

You could also go on the NVIDIA Driver Downloads page and use the automatic detection mechanism via the "GRAPHICS DRIVERS" button, to see if it suggests the same driver package that you have already downloaded. This requires Internet Explorer or having Java installed for other browsers.

  • I do not see any settings in the BIOS relating to this, in fact the BIOS is extremely limited in what it's letting me do. I suppose Samsung just doesn't want it's users to edit these things. Regardless I feel you've probably got the best answer there is available. – AlphaDelta Feb 2 '14 at 11:48
1

This sometimes happens to me, I have to go into Device Manager and disable/enable one of the card for the control panel to update.

As a side note when it's happening the start bar spans across all my monitors (normally with spanning it is only on the primary screen)

Hope this helps.

0

I've found that sometimes if you close the nvidia manager in the bottom left corner of your desktop, then right click the desktop and open nvidia control panel, it sorts itself out.

0

This is by design. The missing settings are either not applicable with your current hardware (it only shows the Stereoscopic 3D section when you have a capable display), or are currently being controlled by another driver (probably the integrated graphics). You should always be able to select the display resolution and related features by using the Windows Display settings dialog, available by right-clicking the desktop.

Using the integrated graphics for the Windows desktop does not normally prevent games from automatically using your discrete graphics hardware. In cases where it does (as determined by in-game performance and diagnostics), you should be able to override by using 3D settings->Manage 3D settings (see here).

If you want a bit more control/visibility over what's going on, check out these features under NVIDIA Control Panel->Desktop:

  • Add "Run with graphics processor" to Context Menu
  • Display GPU Activity Icon in Notification Area

Using the right-click context menu to specify which graphics processor to use could be necessary for non-game applications that may use 3D acceleration (for example WebGL enabled browsers). See for example http://fishgl.com, which displays the rendering speed in frames-per-second, as a way of verifying that this selection makes a difference.


For what it's worth: On my current laptop, the additional settings show up any time I connect and enable an external display. I'm running Windows 10 with the latest NVIDIA driver (384.94). Your mileage may vary, depending on software versions and hardware capabilities.

An interesing note under Manage 3D Settings->Preferred graphics processor:

Programs that launch on external displays that are driven by the NVIDIA GPU will always use the NVIDIA GPU.

0

I found that if you right click on the desktop and click "display settings", go to "graphics settings", set it to classic app and browse for the program you want to use with your nvidia GPU (for example choose the game launcher of the game you want it to run with), click add, then click the program, options, "high performance". Then it should always start with your high-power GPU.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.