I use Debian Wheezy, and frequently make use of Java applications that are famous for being memory-hungry (namely Eclipse variants NetBeans and Aptana Studio 3 on RadRails or PyDev modes). I was having no problem at all with them when I used Oracle JRE. However, I'm using OpenJDK since my last formatting and I started having random unexpected exits from the apps. I then ran Aptana Studio via the terminal so I could see any error messages, and there is what I got when the program closed:

# A fatal error has been detected by the Java Runtime Environment:
#  SIGSEGV (0xb) at pc=0xb00b803d, pid=4748, tid=3076118208
# JRE version: 7.0_25-b30
# Java VM: OpenJDK Client VM (23.7-b01 mixed mode, sharing linux-x86 )
# Problematic frame:
# C  [libsoup-2.4.so.1+0x5603d]  soup_session_feature_detach+0x1d
# Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
# An error report file with more information is saved as:
# /home/gabriel/hs_err_pid4748.log
# If you would like to submit a bug report, please include
# instructions on how to reproduce the bug and visit:
#   http://icedtea.classpath.org/bugzilla
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.

Is this some known issue with OpenJDK or some problem in my machine? How can I solve it? I really need these programs for work.


Edit 1: As Chris suggested, I checked ~/hs_err_pid4778.log. It contains this log, but all I could see from it was that Aptana caused the problem, which I already expected. However the crash seems to be caused by many different modules/methods? I still have no idea how to solve that.


Look for clues in /home/gabriel/hs_err_pid4748.log...

Why do you suspect this is OpenJDK issue and not - foir exmaple - Oracle JDBC's, heap space?

  • I actually suspected OpenJDK because it was the only possible culprit in my mind - apart from hardware failure - since I don't understand much about how Java works. I think you assumed I did because I use Eclipse - however I only use it for Python and a few web-driven high level frameworks. – gchiconi Jan 29 '14 at 14:51
  • Check the OP again; I've edited the logs in. – gchiconi Jan 29 '14 at 19:11
  • Update OpenJDK, give your app more memory. – Chris Jan 30 '14 at 12:08
  • Tried those. I gave 1024M Xmx to Aptana Studio and it still crashes. Logs are too similar so I did not include them this time. I guess it's a problem with Aptana Studio on its own, but it would be strange since I don't seem to find people with the same problem... – gchiconi Jan 30 '14 at 21:55

Use the Oracle JRE.

My company's software, which I'm a developer for, lives on Linux & Java. We used the OpenJDK for a while, but we'd get very random crashes, few and far between. One day, I updated all our OpenJDK instances and started having major issues with our GUI. As soon as I switched to the Oracle JRE, everything worked fine again. No more random/obscure issues.

OpenJDK is supposed to be ~99.99% of the same code as the Oracle release. I guess that 0.001% fills in some pretty key gaps.

  • Thanks, that's what I'll do for now. Not accepting because it doesn't particularly solve my problem and someone can come up with the fix. – gchiconi Jan 29 '14 at 21:22
  • @gchiconi: Yup, I wouldn't accept it either, at least, not for a long while. I hope someone gives you a more direct & specific reply. Seems like OpenJDK is soo close. For me, I've got other fish to fry.. – James T Snell Jan 30 '14 at 4:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.