0

When my USB 3.0 hub is connected, my Ultrabook has start-up problems. The Windows logo appears momentarily then the screen goes black and freezes completely. If I disconnect the USB 3.0 hub and force a re-start, I'll get a BIOS prompt suggesting I start in safe mode but I can start normally and all is well. Once Windows has started, I can connect the hub and everything works fine from there.

The PC has 1 USB 2.0 port and 1 USB 3.0 port. An external USB DAC occupies the USB 2.0 port (makes noise in a hub). The USB 3.0 hub is an Anker 7-port hub (w/ 2 charging ports) and uses a separate power supply. I typically have the following devices connected to the hub: following devices attached: Logitech Unifying receiver, external HDD (my only 3.0 device), printer, and a device on one of the charge-only ports.

I've tried some troubleshooting and found the following:

  • Latest USB 3.0 drivers are installed (Fresco Logic)
  • Starts up okay if the hub is connected via 3.0 port but no devices are connected to hub
  • Starts up okay with a device connected directly to the 3.0 port w/o the hub
  • PC's charging/AC/battery status does not seem to have an affect

Here are some system specs:

  • Asus UX31E
  • Intel Core i5
  • Windows 7 Home Premium X64
1

Have you tried with the hub attached, but with only SOME of the devices hooked to it? Plenty of devices don't like (powered) USB hubs, so it could be one of the devices doesn't like the powered hub, and/or is conflicting with another device while on the same hub.

Try hooking all devices to the hub except the printer, does it freeze? If yes, then hook the printer back in, and unplug the HDD for the hub. Does it freeze? If yes, continue through each attached device, detaching one device at a time and attempting to boot -- hopefully you'll find the culprit.

  • I did as you suggested and it looks like the external HDD is the culprit. Any ideas on a fix? Is this a problem with the boot order/priority? – P Fitz Jan 30 '14 at 4:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.