2

Usualy, after performing a search in MS Word, the shortcuts Ctrl +Page up / down goes to the phrase that was searched previously.

There is a way to disable it by clicking the round button under the scroll bar, then choose "Browse by page", but need to do this after each search separately.

enter image description here


Is there any way to completely disable this auto feature?

2

If what you want is to having Ctrl+PageDown/Up working always as "Go to next/prev page" and you are willing to loose Find Next/Prev functionality for it, here is how to do it:

  1. In Word, press Alt+F11 to open Visual Studio for Application.
  2. Add a new module to Normal. (Right click on Normal in Project explorer box, Insert > Module). enter image description here
  3. Add there the following code:

    Sub JumpNextPage()
    With Application.Browser
        .Target = wdBrowsePage
        .Next
    End With
    End Sub
    
    Sub JumpPrevPage()
    With Application.Browser
       .Target = wdBrowsePage
       .Previous
    End With
    End Sub
    
  4. Now we are going to assign Ctrl+PageDown/Up to run these macros. First, go to File > Options > Customize Ribbon. (I'm using Word 2013, but it should be the same from 2007, and even with earlier versions there is an equivalent way to find the dialog we need.)

  5. Click on “Customize...” button in the bottom of left column appears in the right pane, which has the label “Keyboard shortcuts” before it. enter image description here

  6. Browse to “Macros” category and assign the wanted shortcut key to the macro (making sure use save the changes in Normal.dotm, so it’ll be available to all documents).
    enter image description here

    BTW, you can see that currently the key combination is assigned to “BrowseNext”. This is how I found the command name for the restoring step below.
    enter image description here

    This way you can also remove key combinations that you don’t like, by trying to assign the key to any command, seeing the command name it currently assigned to, searching for this command in “All Commands” category, selecting the key in “Current keys” box and pressing “Remove”.
  7. That's it. Now Ctrl + PageUp/Down will jump pages only, even after some search.

Please note the following:

  • Now, even selecting other objects on “Go To” dialog (the one in your screenshot) will be reset to “page” when you use the shortcut keys.
  • As mentioned above, now you don’t have any obvious “Find Next” shortcut key.
    Still, if you close the Find dialog box, Alt+Ctrl+Y or Shift+F4 work as Find Next! (But there is no Find Previous.)
  • If you want to restore the original key behavior, you can use the “Reset All..." button appears in the same, or just set the specific keys back by browsing to “Commands Not in the Ribbon” category, then to “BrowseNext” and “BrowsePrev” commands and re-assing the shortcut keys to them.
0

Not sure if you can disable it, but you can reassign it. Through Office button > Options > Customize click Keyboard shortcuts.

Assign it to some other random key combination. You could also try removing the assigned button all together from here and see if that helps.

Select All Commands on the left panel and find Browse Next and Browse Previous in the right panel.

  • That can be a solution if there are commands for next/previous search result, but I can't find such commands. – elady Jan 30 '14 at 9:38
  • NP :) , but removing current shortcuts removes the basic PageDown/Up functionality also, and the reassignment solution is applied for the next/previous search results also. so this solution doesn't separates these two functionalities. – elady Jan 30 '14 at 10:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.