I use a laptop. Not a mac, but with a multitouchpad so I scroll down and right click with 2 fingers still.

I hate the fact that if I move too much my fingers over tabs, the scroll will but activated and it will switch to another tab (pretty randomly since my scroll was unintended). It can sometimes be difficult to find my tab bacK.

Is there a way to disable this behaviour? In general, Chrome seems very minimalistic in terms of behaviour customization ...

Someone had the problem on Firefox, which I actually don't have there: How can I disable mouse wheel scrolling of Firefox tabs? Maybe this extension could help, but I have a negative feeling about it. Somebody uses it? https://chrome.google.com/webstore/detail/shortcut-manager/mgjjeipcdnnjhgodgjpfkffcejoljijf

I'm using Chrome 30.0.1599.101 in Lubuntu 13.10.


  • Scrolling over the tabs in Chrome doesn't switch tabs by default. See superuser.com/questions/504687/… for reference Commented Jan 30, 2014 at 12:18
  • 11
    @OliverSalzburg it does on the Ubuntu version, this used to drive me crazy with a trackpad but I don't use Linux any more. I never found a solution but this was a long time ago now.
    – zelanix
    Commented Jan 30, 2014 at 13:16
  • I hope you haven't left Linux for this. It would be sad! But at least if it was an option, it means they asked themselves if it made sense or not. And as every option, some people like it, some don't... I'll keep searching the web Commented Jan 30, 2014 at 15:40
  • 1
    Has anyone found a solution to the problem yet? I just installed Linux Mint and it's already starting to get annoying Commented Sep 22, 2014 at 9:57
  • 5
    This 'feature' has been in Chrome/Chromium since 2008. For 7 years it has haunted, taunted and annoyed Linux users. It's still going strong.
    – Mave
    Commented Jun 4, 2015 at 11:24

2 Answers 2


As of today this is built-in functionality within Chrome GTK/Linux only. Here is the key thread discussing the change: https://code.google.com/p/chromium/issues/detail?id=1316

Windows users must use Chrome Toolbox (by Google) or an alternate solution. Unfortunately this extension and its control options aren't available on Chrome Linux's latest versions due to the drop for NPAPI support, as mentioned in the extension FAQ.

As a result, the only option I see is to pull down the source code for Chrome and modify the source, which I've done personally to make tweaks. It's not that hard to do and would be the route I would take. For this particular feature, I would simply undo / rollback the following change and recompile:


If you click the "View" link under the column Side-by-side diffs and change the files to match the red version (old), that should essentially do the trick. Sorry this is technical in nature, but it would certainly solve the problem. Alternative suggestions welcome.


Works on ubuntu 20, chromium 93:

  • go to chrome://flags/#scrollable
  • to enable scrolling, set to defaults: "Tab Scrolling" and "Tab Scrolling Buttons"
  • to disable scrolling, enable: "Tab Scrolling" and "Tab Scrolling Buttons"
  • Restart chrome/chromium
  • This one worked, thanks
    – rofrol
    Commented Oct 12, 2021 at 14:37
  • thanks, worked in chrome 96 Commented Dec 12, 2021 at 22:26
  • 5
    The description on "Tab Scrolling" says it does something else, but enable this and the mouse wheel does nothing when hovering tabs! Thanks!
    – JasonWoof
    Commented May 25, 2022 at 14:57
  • 2
    This should be the accepted answer. Commented Jul 31, 2022 at 11:36
  • 1
    This just worked for me! Chrome 121, Ubuntu 23.10, Gnome 45.2, if that matters. Note that the thing here is to set those two options to "enabled" to disable tab scrolling! I read the answer quickly and had it backwards at first and thought it didn't work. Counter-intuitive option names! Commented Feb 19 at 17:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .