6

I am logged into a remote computer with TeamViewer. I can see the remote desktop which is asking for me to enter my passcode. However when I type my passcode on the keyboard, nothing is being entered. In short my keyboard input is not coming through at the other end. Mouse gestures seem to be working however.

  • If you have a local laptop or client, can you log in, open up a text editor and see what typing remotely then gets you? – Danny Staple Jan 18 '15 at 12:50
6

My steps:

Disable: Action -> Send key combination
Enable: Action -> Send key combination
Ctrl+Shift+WinKey
  • This works for me too :) – Rajamohan S Dec 17 '17 at 8:51
5

This is actually more of a response to this question, but I thought would still be relevant here.

I just ran into a similar problem a few minutes ago: I could interact with the remote machine with my mouse, but all keyboard input remained inactive (this is the first time I have experienced this issue with Teamviewer).

I tried checking through multiple options, particularly "disable remote input", and nothing worked. In my case, I use Tv as a mere lazy convenience to access a machine in another room of my house so, after discovering this issue, I just decided to see if there was anything wrong on the remote machine itself. Turns out, I had no input control on that machine - not keyboard or mouse - even when I had ended the Tv session.

What ended up resolving the issue was pressing ctrl-alt-del on the remote machine to bring up the help/lock screen, and that was it! Just from that, I regained full control both locally and remotely.

I'm not sure why I hadn't thought to try that through Tv itself; I don't know if I could have solved it without going to the remote machine, but hopefully that is helpful to anyone else with this problem.

2

I had some issues with the remote keyboard and some keys where just not working at all or doing strange thing like min/max windows, close aplications and so on. Here is what worked for me:

  1. Ensure keyboard is enable on the client
  2. Ensure remote control is activated
  3. Send a CTRL+ALT+SUPR from Teamviewer menu bar and lock the screen
  4. Try to access again with your username/password

I did that and everything come back to the normal state.

1

You need to ensure keyboard is enabled on the client end. Ensure remote control is activated.

You do this on the bar which appears when a connection is established on the client end.

0

This action is worked for me.

First make sure: uncheck "send key combinations" from "Action" menu, and I can type on remote computer again.

-1

Teamviewer temporary fix Windows7 +???? If your host keyboard does not function but your mouse does, on your client’s computer, a quick temporary solution to get your work done is this:

  1. Log onto your client computer
  2. Go to {Control Panel}
  3. Go to {Ease Of Access Center}
  4. Click on {Start On-Board Screen Keyboard}
  5. The keyboard should show up on your clients desktop, adjust size to your needs.
  6. Unlock your task bar then drag and drop to your task bar then lock it in for future use.

It’s only a temporary keyboard that will function with your mouse until someone figures what WINDOWS UPDATE screwed it up. I will be doing a new W7 install on another machine with zero updates loading only TeamV and monitoring the updates (277 in all) until it happens again. I will post which one it is.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.