I downloaded the .deb file from Google chrome website. Then started installing. But suddenly the software center shows a dependency not satisfied error. Some thing like given below.

Dependency not satisfiable:libnss3 (>=3.14.3)

Then I have tried all these.

But not yet solved..Still the same issue.

Please give an advice on this.

  • If none of those work, how did they fail? And what did you actually attempt?
    – Dan D.
    Jan 31, 2014 at 9:29
  • I really don't know what is the issue here. Still it shows the same in Software Center. Whenever I try to install libnss3 by sudo apt-get install libnss3 it says libnss3 is already the newest version. What could be the issue. I think, the installed version is not greater than 3.14.3. If that is the case how can I upgrade to the lateset version. Is there any version compatibility issue with Ubuntu OS, like Ubuntu 12.04 can install libnss3 version less than 3.14.3!! Jan 31, 2014 at 9:50
  • I'm just guessing: have you tried to run sudo apt-get install libnss3-dev?
    – Dario
    Feb 1, 2014 at 18:26
  • Dear Dairo, Still it shows the same issue :( Feb 4, 2014 at 5:04

1 Answer 1


Got it solved from this link http://packages.ubuntu.com/precise/amd64/libnss3/download.

  • As it says added this line deb http://security.ubuntu.com/ubuntu precise-security main at the end of /etc/apt/sources.list
  • sudo apt-get update
  • This may cause gpg key error.
  • sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 8BAF9A6F. (Refer: https://askubuntu.com/questions/13065/how-do-i-fix-the-gpg-error-no-pubkey).
  • Again run sudo apt-get update if gpg error had occured.
  • sudo apt-get install libnss3.

This installed me with latest libnss3 and it solved issue with installing google-chrome.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.