8

I'm trying to do a port upgrade outdated, but it stops on a package conflict that I'm not able to fix.

Does anyone know how to fix this problem?

sudo port upgrade outdated
--->  Computing dependencies for subversion-perlbindings-5.16
Error: Unable to exec port: Can't install subversion-perlbindings-5.16 because 
conflicting ports are installed: subversion-perlbindings-5.12
1
  • 1
    Do you think my answer below is an acceptable answer to macports? while brew is an option, there are still people that prefer macports and my answer might be the right answer for them.
    – Yehosef
    Feb 6, 2014 at 9:20

2 Answers 2

14

I had the same problem. I did:

sudo port deactivate -f subversion-perlbindings-5.12

which allows me to install the new version of the perl bindings.

3
  • 1
    I can't confirm that this works with my problem, because I removed macports and installed homebrew. However, if you are saying that you had the same problem, I think your answer should be accepted because it solves the problem. I'll search a little bit more to know if your answer could be accepted.
    – javsmo
    Feb 3, 2014 at 18:35
  • another note - right after the deactivate I ran "sudo port install subversion-perlbindings-5.16" and then did a "sudo port update outdated" and everything updated without problem (git, python, php54, mongodb, mysql, curl, etc) I haven't had any additional problems.
    – Yehosef
    Feb 4, 2014 at 12:30
  • I'm not sure if they install of the 5_16 version is necessary or it'll happen automatically (I assume the latter) but I'm just including it for completeness.
    – Yehosef
    Feb 4, 2014 at 12:33
0

I prefer brew: http://brew.sh

There are tutorials like this teaching how to port from macports to homebrew.

3
  • I've been told that brew is better than macports in many aspects. If nobody answer the question, suggesting some fix with macports, I think I'll be forced to migrate to brew.
    – javsmo
    Jan 31, 2014 at 14:02
  • After one day without other comments, I'll accept your answer, give up macports and install homebrew...
    – javsmo
    Feb 1, 2014 at 13:22
  • I had to accept Yehosef's answer, as it was related to macports, although your answer have solved my problem another way.
    – javsmo
    Feb 6, 2014 at 12:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .