9

I am running Mavericks on a late 2013 model MacBook Pro 13" Retina (Intel i5 chip) and have installed Windows 8.1 into a bootcamp partition. Under Bootcamp, an attempt to start a VM in Hyper-V Manager results in the error message that the VM "could not be started because the hypervisor is not running."

Per Hyper-V Service Manager, the service is started, and I've eliminated the three potential causes provided in the details of the above error dialog box, namely:

  1. Hardware supports virtualization - it's an i5 and I ran coreinfo to confirm that SLAT is available.
  2. BIOS configuration - for a Mac, there's no option to tweak BIOS-type settings, but HW virtualization is supposedly enabled by default.
  3. BCD configuration issues - I checked bcdedit and the hypervisorlaunchtype setting is auto, but reset it and restarted just to be sure.

Additionally, I have set up Parallels 9 to used the Windows 8 bootcamp partition, and when I launch into Parallels, I have no problem setting up and starting a VM. Those same VMs that I've created there, then fail to launch if I restart the machine directly into bootcamp.

What am I missing?

6
  • Did you figure anything out yet? I am also trying to run Hyper-V in boot camp. Hardware Virtualization does not seem to be enabled by default, I also have a Macbook 2013 and Virtualization appears as disabled under the Performance tab of task manager. – msbg Feb 16 '14 at 0:05
  • Apparently, this is due to limitations in how Boot Camp invokes Windows (namely CSM). If you use rEFInd to somehow install Windows in "native UEFI" mode, you might have better luck. – Daniel B Feb 18 '14 at 0:21
  • Thanks @DanielB; while that may be true, I can confirm using rEFInd and checking that Windows is booting in UEFI mode (via this method) does not guarantee you would avoid the OP's error (I'm getting the same). For me it's a hit and miss, mostly starting up from shutdown works and restart doesn't.. Hoping to get other suggestions. – Jonno Jun 16 '14 at 10:46
  • Check the output of coreinfo for these required CPU extensions/flags: vmx (virtualization), nx (data execution prevention), ept (second level address translation), and vmm (VM Monitor Mode). If they all exist, the usual remedy, to execute "bcdedit /set hypervisorlaunchtype Auto", may not be relevant to bootcamp. – harrymc Jun 17 '14 at 10:51
  • 2
    If I understand right, this is now working for you, so better leave an answer as to what you did. – harrymc Jun 24 '14 at 13:06
5

This seems to have something to do with how you boot the Windows partition.

https://apple.stackexchange.com/a/122071/88382 suggests rebooting into OS X, choosing BOOTCAMP from the Startup control panel, and then booting into Windows. This enabled virtualization on my machine. (I had previously booted into Windows using the Boot Camp Assistant, and virtualization was disabled.)

3
  • This is a workaround to a firmware issue that Apple is actively hiding behind their utterly useless support. Issue has been around from 2008 and it's a software related bug that seems to be re-introduced into new models once is a while. – Sean Feldman Dec 30 '14 at 16:13
  • My bootcamp partition is BitLocker encrypted, so I don't see it in the Startup control panel. Any other technique? Ridiculous this bug hasn't been fixed by Apple for over 8 years. – DeepSpace101 Apr 13 '16 at 14:54
  • This worked for me; however, I had to set the OSx as the default target drive. I have to boot into OSx, then soft reboot to Windows and then I have full HyperV options now. I'm using a Macbook Pro Late 2013 with the macOS 10.14: Mojave (Liberty) installed. – HPWD Feb 16 '19 at 19:28

Not the answer you're looking for? Browse other questions tagged or ask your own question.