1

Graphics Card: AMD Radeon r9 270x

Screen : Samsung F5000 series 32 inch LED Full HDTV.

Cable : HDMI cable connected to my graphics card's HDMI slot, and to my screen's HDMI slot.

OS: Windows 8.1 x64

The max resolution I can set and still see screen is 1920x1080 30Hz... In CCC driver settings it shows that TV is capable of full HD 1080p 60hz (and I know it, because I can easily connect my NB with GT540m with no problem) and it lets select it, but when I set this setting, TV shows that there is no signal or Resolution not supported (Actually it auto sets 1080p 60hz after Catalyst driver install so I had to boot windows in low resolution mode to change that 1080p to something lower) . Hovever everything works just brillian (1080p 60hz) just after fresh windows (8.1) install until at least windows native amd display drivers are installed. Any solution how can I use proper Full HD with this graphics card? As clearly 1920x1080 30hz is totally unusable so Im currently running on 1680×1050@60hz which is not what I paid for.

UPDATE: After Driver update to 14.1 beta (was using 13.10) even 1680x1050 60hz stopped working. SO now max 60 hz resolution I Can get is 1600x900 60hz... Everything above works on 30hz only. Same with 13.12 drivers..

  • is running 1080p and 1080i that big of an issue for you? you can actually see a difference? i find it hard to believe you can. – Sickest Feb 1 '14 at 19:23
  • You probably didnt knew.. but (1080i) 30hz refresh rate means that TV wont display more than 30 fps... Do you think I bought r9 270x to play games on 30 fps? :) – DadaB Feb 1 '14 at 19:51
  • just a nitpick, but 720i is "full" HD. You just want 1080p – Keltari Apr 29 '15 at 23:22
1

Inside the catalyst control center, there is a options to add the resolutions which are currently unavailable, add your required resolution with refresh rate, then apply it.

  • The needed resolution IS listed in settings and IS shown as available. However when I switch to it Im getting black screen with HDMI not connected error. – DadaB Feb 1 '14 at 18:37
  • Just check in your tv setting, if there is a gaming mode, turn it on while switching resolution. In my Toshiba TV it was there named noise reduction. According to my knowledge, The Full HD TV have some image Post processing job, so the tv processor decodes every single frame. This job can't be done at high resolution because these processor are not so powerful. So turning off this post processing may solve your issue. Please note that this kind of setting varies from tv to tv, model to model. Usually they can be found as gaming mode or nose reduction. – user293750 Feb 1 '14 at 22:45
0

You may be running into an issue with the color format.

You should have a choice between YCbCr 4:4:2, YCbCr 4:4:4 and RGB (HDMI Limited/Full Range) if you look really closely under the panel settings in Catalyst Control Center.

Generally TVs are guaranteed to support the Luma/Chroma (YCbCr) formats for all refresh rates but not RGB. It is the opposite story for general purpose monitors, most of them only support RGB.

I would suggest you try using YCbCr 4:4:2 and see if that changes anything. I prefer Luma/Chroma for TVs personally because even when configured in the menus to use full-range RGB many TVs still clip full black/white over HDMI. You probably would never notice this unless you have your TV properly calibrated, but RGB is more trouble than it is worth for TVs.

  • Tried all possible formats. Still no use. – DadaB Feb 3 '14 at 21:03
0

Ok so I had the same issue Im currently running this with a 3 monitor setup. windows 10 64 bit PowerColor Radeon RX480 8gb 16 gb ram AMD Athlon X4 860(Black edition) AMD Radeon Adrenalin software

What I realized after 30 mins of hunting. It Is a scaling issue, AMD Drivers sometimes have a hard time recognizing a monitors potential. The software changes regularly and we now have Radeon Adrenalin This issue i exparamented with and was able to fix on my other 2 monitors using the "HDMI Scaling". But my middle moniton being a Dynex Tv had issues. It always turned on with the pc in 1080i and never would change. Windows would only give me 1920x1080p(but i had the scaling issue. Top bottom and sides would be cut) and 1280x720(it would just make all my monitors blackscreen. And I only adjusted that 1 monitor.) Windows "Display settings" wasnt help Radeon software didnt help. Well. It was a setting on my TV See if you have a setting called "overscan" or something close to it. I turned it off and it snapped everything in place. Crystal clear. Doesnt look pixilated,or fuzzy.

Previous card was a GTX 960 and it had issues finding the resolution .

UPDATE: I lied,After I opened a game on my primary monitor(far left). My center monitor went straight back to 1080i. Doesnt crop out the corners or sides.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.