1

I have windows 8 PC with 16GB Ram and 2TB hard drive. Drive C has 150GB allocation with only 3.5GB left. Drive D has more than 1TB left.

I use TeamViewer to remotely connect to my PC. This morning, all of a sudden, I get an alert in TeamViewer that my remote PC has low free space in Drive C. I haven't been monitoring this and after I checked, only 3GB is left.

I went inside drive C, made hidden files visible, selected everything and checked properties. It only shows 75GB worth of data. Something else is taking up space in my PC. Does anyone know what this could be and how to free it up. Before this happened, my PC became really slow and I restarted it. Now it's working fine, but it seems like it has eaten up some space.

I'm running 3 Virtual Machines constantly, 2 RDP sessions, video editing program, a couple of projects in Visual Studio and some other applications before restarting the PC.

UPDATE: I checked my Virtual Memory settings under Performance Options and it seems like the current allocated pagefile for all drives is 49152MB. I think this is what caused the full disk usage of drive C. Is it better to manually set the pagefile limit or just let the OS auto manage it? How can I clear up the currently allocated 50GB of pagefile?

  • 1
    Get WinDirStat and check what's taking up so much space. – and31415 Feb 1 '14 at 23:06
  • @WinDirStat I have updated my question to reflect further information I found. I think this is an issue with the page file. – John Ng Feb 1 '14 at 23:11
1

Microsoft has a guide here on how to change the pagefile's size:

  • Open System in Control Panel.

  • On the Advanced tab, under Performance, click Settings.

  • On the Advanced tab, under Virtual memory, click Change.

  • Under Drive [Volume Label], click the drive that contains the paging file you want to change.

  • Under Paging file size for selected drive, click Custom size, and type a new paging file size in megabytes in the Initial size (MB) or Maximum size (MB) box, and then click Set. If you decrease the size of either the initial or maximum page file settings, you must restart your computer to see the effects of those changes. Increases typically do not require a restart.

  • Thanks, and I am already in that settings page. I'm not sure what the suggested page file size should be though. And the current auto allocation is 50GB, how can this be cleared up? – John Ng Feb 1 '14 at 23:16
  • Just change it to something smaller. My pagefile is 1.25GB, you should be fine with that. – Jon Feb 1 '14 at 23:18
  • Thanks @chipperyman573, I've set it to initial 1GB and max to 5GB. – John Ng Feb 1 '14 at 23:29
  • 1
    While most of the guide still applies, the recommendations were meant for Windows XP, and are outdated now. Here's a newer KB article: support.microsoft.com/kb/2860880/en-us – and31415 Feb 1 '14 at 23:59
0

I would look in the video editing programs folders if I were you. 150GB is nothing when it comes to video editing.

Try browsing to the programs folder and right-clicking properties to see the size of the folder. Over the years I have tried many video editing programs and noticed some leave copies of all your media within the programs directory.

Another thing to try is running a disk cleanup to free up your C disk from temporary files.

UPDATE to updated question.

It's the pagefile for sure. Manually setting or allowing the OS to automatically manage it can vary on situation. If you have a fast processor, good video card, lots of memory then you can have the Microsoft Windows Operating System automatically manage your pagefile. But if you have a poor performing system, a simple but effective hack would be to manually manage the pagefile. So if you only had 512MB of RAM you could manually set your pagefile to use your hardrive as virtual RAM and set the amount you'd like to use for memory. I recommend setting the max pagefile size to no more than 2.5 times your actual RAM size. So for example, if you have 512MB of RAM, set the lowest pagefile size to 512MB and the max pagefile size to 1280MB.

In your case I would allow the Microsoft Windows Operating System to automatically manage your pagefile. Once you revert back to this default option the pagefile will be cleared.

  • Thanks but all the files used for the video editing program is in partition D. Also, I think the problem is with page file. I have updated my question with more information. – John Ng Feb 1 '14 at 23:11
  • @Jonh Ng I have updated my answers to reflect and answer your updated questions. – Giancarlo Colfer Feb 1 '14 at 23:27
  • The original settings was actually to let the OS manage the page file and it automatically allocated 50GB of pagefile. Probably because of all the applications I am running. I have set this to manual now and used max of 5GB. – John Ng Feb 1 '14 at 23:28
0

Reducing the page file size

  1. Go to Control Panel > System and Security > System.
  2. Click Advanced system settings.
  3. On the Advanced tab, under Startup and Recovery, click Settings.
  4. Select Small memory dump from the Write debugging information section, and click OK.
  5. Go back to the Advanced tab. Under Performance, click Settings.
  6. Under Virtual memory, click Change.
  7. Uncheck the Automatically manage paging file size for all drives option.
  8. Select the C: drive from the list, click Custom size and select both Initial and Maximum size to 4096. Click Set, and then click OK.
  9. Restart Windows to apply the changes.

Remarks

64-bit versions of Windows and Windows Server support more physical memory (RAM) than 32-bit versions support. However, the reason to configure the page file size has not changed. It has always been about supporting a system crash dump, if it is necessary, or extending the system commit limit, if it is necessary. For example, when a lot of physical memory is installed, a page file might not be required to back the system commit charge during peak usage. The available physical memory alone might be large enough to do this. However, a page file or a dedicated dump file might still be required to back a system crash dump.

When the page file is system managed, it will take up to 3x the amount of RAM installed. For example, if you have 16 GB the page file will grow up to 48 GB (49152 MB).

4096 MB (4 GB) is the minimum system-managed amount for the maximum page file size. Enabling small dumps allows you to avoid complete memory dumps while keeping a smaller page file, which wouldn't be able to back them up.

Considering you got 16 GB of RAM, the above settings might work for you, or it might not. It all depends on the way you actually use your system. You have to try it out, and adjust the size again if necessary.

References

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.