2

I use Windows 7 Home Premium. What happens is, when my computer runs idle for a while, I get disconnected from all the IRC servers I'm connected to. My client does not figure out it's been disconnected until I unidle, even if it was disconnected hours ago. I don't think it's a problem with my IRC client, namely mIRC, although I admit the possibility exists. I've used mIRC for many years, and this particular version for probably a couple of months, and it's never done this before.

The only sleep mode option I have enabled is to turn the monitor off after 15 minutes idle. The computer is set to never go to sleep. I've double-checked that nothing has touched these settings. I've also double-checked that no screensaver is enabled, so it can't be that.

I've had this computer and OS for a year and a half and it never used to do this, but it's done this several times now, although it doesn't do it consistently. It might just be that it doesn't do it if mIRC happens to be the active program when I idle.

The way the IRC client doesn't realize it's been disconnected, yet suddenly does as soon as I move my mouse to wake up the computer, suggests to me that mIRC stops receiving clock cycles for some reason. I also notice that, every time this happens, mIRC gets shifted to the rightmost position on the taskbar, even though that's not where I keep it -- almost as if it had been closed and reopened. Could the mIRC process be getting "swapped out" in some sense? It's the only thing I can think of.

I wonder if the distributed computing program BOINC (or the program I run with it, rosetta@home) might be related to this problem, since it's supposed to run whenever CPU usage is light. I'm loath to try to turn it off to find out, since I'll probably just forget it's disabled.

1
  • I've rebooted my computer and this may have fixed it. I know, I should have thought of that before, but it really didn't occur to me that I hadn't already rebooted my computer since the problem had started. Feb 7, 2014 at 2:34

1 Answer 1

0

See @ http://social.technet.microsoft.com/Forums/windows/en-US/378529f9-b455-47ec-99eb-97b10aabb327/windows-7-wired-network-adapter-enters-power-save-mode?forum=w7itpronetworking

You can perform the steps below to disable this device from being disabled to save power:

  1. Click "Start", input "Device Manager" (without quotation marks) in the Search box, and then press "Enter".

  2. Double-click "Network adapters" to expand it.

  3. Right click the network adapter and then click Properties.

  4. On Power Management tab, uncheck "Allow the computer to turn off this device to save power".

  5. Click OK.

2
  • OK, I went there and that box was indeed checked. I've unchecked it now and we'll see if it fixes it. I'll mark your answer as accepted for now and post again if it doesn't work. Thank you! Feb 2, 2014 at 20:54
  • Nope, that's not it. I just had the problem again even though that box is still unchecked. Sorry! Feb 3, 2014 at 4:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.