OK, so here is the problem I'm hoping you guys can help me fix. On my Win7-Ult64 box, my explorer (among other things) has decided not to work. For example, if I try to use a program, say Chrome, to open a folder, I will get the message "Class not registered" (and its not program specific).

In the same vein, when I go to Start->Rclick Computer->properties, nothing happens, but I can go to control panel->system properties and it will work. And other items in the control panel do nothing when I click them (and I have a feeling it is all tied together).

I have already done multiple virus and spyware sweeps, so I know that isn't the problem. Any suggestions on what could be causing this/how to fix it (short of nuke and boot)?

  • No answers here, but similar issues with "Documents". I'm with W7 RC (7100). Any others with reports? – outsideblasts Nov 16 '09 at 9:23
  • You don't say what build this is ie is it Windows 7 beta? RC? RTM (final)? – AdamV Nov 16 '09 at 10:17
  • sorry, yes it is build 7600 (final/retail) – Cegorach Nov 16 '09 at 15:25
  • Have you tried System Restore? – fretje Nov 16 '09 at 18:46
  • Not really, because this problem has been around for a while and it just now started irritating me, so I have no idea how far back the problem exists. – Cegorach Nov 17 '09 at 6:02

When in doubt, reinstall. :) If you are a good computer user, everything important is already backed up. Also a win7 install takes about 20-30mins on a good computer. Heck it only took an hour when I installed it on a p4.

Things happen. Hard drive sectors go bad and you lose important system files. I know it sucks but honestly it is probably the most stable solution.

  • Note to self, check time stamps. Funny though, this question made it to the front page... – Tony Jun 11 '10 at 11:57
  • Best solution here. But who would open a folder using Chrome. – JL. Sep 1 '10 at 12:16

I, Too, used to experience this problem. It can be associated with other problems as well, such as the explorer navigation pane becoming non-operational, or other GUI elements becoming screwed up.

Luckily, I somewhat indirectly found a solution. The remedy is simply replacing a system file located in the C:\Windows\System32 and \SystemWOW64 folders; this file being named "ExplorerFrame.DLL." This file is, in essence, the parts of the explorer GUI that a simple personalization theme CANNOT change- the forward and back buttons, the sidebar, etc. Apparently it also controls how applications get to open explorer, and if at all.

A Couple weeks ago I finally decided to fix a problem that i mentioned earlier; my navigation pane was non operational, making some applications completely useless. I was also getting the "Class Not Registered" errors in some applications, but this wasn't as big a deal.

Replacing the Explorerframe.DLL file not only fixed my navigation pane, but additionally, ceased the appearance of the earlier mentioned error messages.

The only problem is that this specific DLL file is quite hard to find on the internet. If you have a backup of these files, then pull the Explorerframe.DLL file from there, or, if you feel like customizing your GUI a bit, then download a custom one from a site such as DeviantART.


Try running System File Checker. Hit Win+R and type sfc /scannow and enter. This will take a while, when it's done, restart your computer.

  • Unfortunately that didn't help. – Cegorach Nov 16 '09 at 15:43

...or try to scan with malwarebytes in safe mode


It's really weird. Have you tried system restore or put your OS disk and repair it ? It may fix the problem . In many times, when I meet this kind of problem, you better backup your important data first, after that do check your system.

If it's not fixed, reinstall your OS is the best choice :)


If you have Antivirus, Update your virus definitions and try to scan your Windows 7


Once this happened to me in Vista, and the problem was that Windows lost the EXE file association, i.e. it didn't know what to do with EXE files.

At the time this page helped me fix it: http://www.dougknox.com/xp/file_assoc.htm

Look for "EXE File Association Fix". It's made for Windows XP 32, and it worked for me on Vista 32, and I believe it also does on Windows 7 x64. I am on a Windows 7 x64 right now and checked some of they keys in the .reg file and it seems to have the same keys/values.

Before applying the fix, be sure do to a full registry backup, at least for HKEY_CLASSES_ROOT.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.