10

We have several processes that email logs or other text files to us. When they have the extension .txt, Outlook knows how to show the preview within its main window. When the file has an extension such as .log, then Outlook will only offer to open it in an external application, even though the file is plain text.

How can I add .log to the list of extensions that Outlook will preview within its main window?

  • Have you assigned a program to the .log extension? – Ramhound Feb 4 '14 at 19:51
  • Duplicate of this? – shinjijai Feb 4 '14 at 19:52
  • @Ramhound Yes. On my machine, the default viewer for .log is Notepad++. – techturtle Feb 4 '14 at 20:38
  • @shinjijai It is basically the same question, but nothing in that one seems to apply for me. My Outlook already opens CSV files, despite not appearing to have any of the registry keys they mention. I couldn't make heads or tails of what to do with those answers. – techturtle Feb 4 '14 at 22:16
12

In Windows Explorer right-click any .log file and select "Open With..." -> Choose Default Program. Select Windows Notepad there (not Notepad++) and make sure that you have the "default" check set. Restart Outlook. Not it has to show you .log files.

Update:

If not, check HKEY_CLASSES_ROOT\.log registry key's (Default) value. It has to be "txtfile" (without quotes).

  • 1
    Tried this and it didn't work. Still gives the error "This file cannot be previewed because there is no previewer installed for it." – techturtle Feb 6 '14 at 16:56
  • 1
    Ok, that's weird. Please look at the HKEY_CLASSES_ROOT\.log registry key's (Default) value, what is it? It has to be "txtfile" (without quotes). – thims Feb 6 '14 at 17:25
  • 2
    THAT fixed it! It had something in there to do with Notepad++, but once I changed it to txtfile it started working. The default program is still Notepad++, but now it works in Outlook! I suggest you amend your answer with this data and I can accept it. – techturtle Feb 6 '14 at 17:52
  • I just updated the original answer. – thims Feb 6 '14 at 18:04
  • 1
    Sigh. I now have Office 2016 on Windows 10 and this no longer works. No idea if it's the Office or Windows version that broke it, but all of these options were already set properly and changing/resetting them did nothing. – techturtle Nov 7 '16 at 16:33
0

Thanks thims, This worked for me to change my CSV files to preview with a TXT previewer instead of Excel.

crazybilly, If you haven't already gotten your answer, I would guess you can use the following that used to be in my .csv class.

~~~~~~~~~~~~

[HKEY_CLASSES_ROOT.csv] @="Excel.CSV" "Content Type"="application/vnd.ms-excel"

[HKEY_CLASSES_ROOT.csv\Excel.CSV]

[HKEY_CLASSES_ROOT.csv\Excel.CSV\ShellNew]

[HKEY_CLASSES_ROOT.csv\OpenWithProgids]

~~~~~~~~~~~~

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.