I'm using Lubuntu 13.10, and I want to load byobu automatically when I open terminal.

I found byobu very flexible and reliable tool and want to use every time when I have to use terminal.

I couldn't find this solution or something similar to this at man pages...

Any suggestions?

2 Answers 2


I think what you want is to launch the Byobu desktop application. You can find that in the Ubuntu application launcher, by simply typing Byobu. You can lock it to the launcher, and the icon will always stay there, on the left.

Alternatively, most Linux terminals can be set to run a particular command or application at launch.

For instance, in Gnome Terminal, simply click Edit -> Profile Preferences, select the Title and Command tab, check the Run a custom command instead of my shell box, and enter /usr/bin/byobu.

Gnome Terminal preferences

Full disclosure: I am the author and maintainer of Byobu.

  • I'm using Lubuntu 13.10 - with LXTerminal. It doesn't have this configuration. Does exist some way to achieve this goal on Lubuntu?
    – catch23
    Feb 5, 2014 at 9:11
  • sudo apt-get install gnome-terminal Feb 5, 2014 at 12:31
  • It works fine, however is there a way to not have the log message printed every time a terminal is opened ?
    – n0p
    Oct 6, 2015 at 13:01
  • Dear Dustin, Is there a way to start the terminal WITHOUT the welcome-message with the annoying "Press <enter> to continue..." message?
    – ExploWare
    Mar 7, 2016 at 23:52
  • I don't know what enter to continue message you're talking about. Mar 8, 2016 at 13:54

You can use the byobu-enable command. See the related man page. To reverse the change, use byobu-disable.

byobu-enable places a line at the end of ~/.profile. This means it only takes effect for login shells, i.e. via SSH or the VTs. If you're using LXTerminal, it may work if you move that line to ~/.bashrc instead.

  • 1
    I tried this - but after reopening terminal, I need to type byobu for it starting again
    – catch23
    Feb 4, 2014 at 20:19
  • Revised my answer with more details. Feb 4, 2014 at 20:24
  • It really uses - LXTerminal. It places - _byobu_sourced=1 . /usr/bin/byobu-launch at the end of .profile. What exactly should enter to turn it?
    – catch23
    Feb 4, 2014 at 20:31
  • You could configure your gnome-terminal to run as a login-shell, and then this solution will work.
    – jgomo3
    Sep 2, 2017 at 17:41
  • I had to add the _byobu_sourced=1... line to to my ~/.bashrc
    – Tek
    Nov 2, 2019 at 9:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .