2

I have a striped storage space with a 4 drives in it. One of the drives is a USB 3.0 Seagate drive which died recently. I wasn't able to make any progress with it in the USB enclosure (and it is out of warranty), so I pulled the disk out. I have it in a temporary Thermaltake Blacx enclosure now and I can test it and data seems to read off of it fine according to the SeaTools generic tests.

My problem is that windows doesn't recognize the drive as the 4th drive in the storage space. Probably because it isn't a "Seagate Expansion Desk USB Device" anymore.

Is there a way to manually change the configuration to replace the old drive Id with the one presented by the shucked drive?

The data isn't particularly important, so I don't have a backup. It'd be very convenient if this is possible to fix though.

The storage space is in Simple mode. Meaning their version of JBOD/Raid 0. So there is no parity.

  • Assuming your talking about the "drive in a box", it has always acted like any other drive, just in a box :-) Some of the different drives they put in the boxes have software , and even software in the early blocks (like maybey the MBR or whatever). So one differance might be some stuff written to make it backwards compatable, and to access easily more than 2TB in systems. One way to completely clear and check a drive might be to use seagates own tools, once this drive is hooked internally to the sata, the seatools can wipe out everything and return it to more raw. – Psycogeek Feb 5 '14 at 4:22
  • The idea isn't to wipe it clear, it's to make the storage space use the data that's already on the drive. The storage space just doesn't recognize the device id. – Mike Feb 5 '14 at 4:25
  • As far as adding it to a stripe, adding stuff to raid systems that are already set-up is (IMO) a bad idea, so depending on what your doing it could be a bad idea? You see in my opinion raid systems are set-up once locked down to that assembly then just used, adding things on the side using cheap tricks isnt as perfected. Using it as a backup for a striped system might make more sence. – Psycogeek Feb 5 '14 at 4:26
  • Ohhh, (re-read more) you striped a external enclosure with What? Where is your backups then? So this question is more about Data Recovery ? to get it back into a set, which was created How? with OS software assembly? – Psycogeek Feb 5 '14 at 4:33
  • I pulled the drive from the external usb drive. It still has the same exact data on it from the storage space. If I could make the storage space recognize the drive, it would fit perfectly. The storage space is looking for a Seagate USB drive. I want to change the drive id to the id the drive presents to the OS now – Mike Feb 5 '14 at 4:45
0

Try booting in a Linux live DVD (IMO, use Ubuntu 12.04 LTS). And connect the drive to your PC. There, it should most probably work. You can then backup your data and then simply format your drive. If you want, you can stripe it again and put back your data in it.

For booting in Ubuntu, I suggest using Linux Live USB Creator (aka LiLi). You can find it at www.linuxliveusb.com

edit : http://www.raymond.cc/blog/changing-or-spoofing-hard-disk-hardware-serial-number-and-volume-id/. This will help you change the serial number. I tried and the second listing, sysinternals volume id worked perfectly.

| improve this answer | |
  • Please re-read the question. Copying the data off the drive gets me nowhere. I'd just have to somehow slip the new disk into the storage space. Placing me right back where I started. I'm looking for an answer which would allow me to modify the Storage Space definition somewhere and change the old drive ID to the new drive ID. – Mike Feb 13 '14 at 0:53
  • Ok. sorry, I read too fast. Would you mind reading the edit. – user3459110 Feb 13 '14 at 12:02
  • still, I dont think its gonna help out in any way. but i thought i should do what i can... – user3459110 Feb 13 '14 at 12:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.