2

My home pc is win7 64-bit and I do not have a supported client for my work vpn (checkpoint). As a workaround I used to use a virtual pc, but it is no longer supported by my hardware.

Right now i'm nesting RDP's with my desktop and work laptop that can connect.

Is there a way to tunnel my rdp connection from my desktop through the laptop without nesting RDP sessions?

3 Answers 3

3

Nested RDP (If you mean RDP in to a RDP) is annoying, but your best and quickest bet.

Other than that, have you tried different virtualisation software?

If you are talking about Microsoft Virtual PC and your new machine does not have the VT bit, you may want to take a look at Sun Virtual Box... It works fine and has lesser requirements than Virtual PC or VMware Workstation.

3
  • Yea this is where I left off. I was thinking vmware but will look at the sun product. Still has the RDP -> RDP issue but it works.
    – jms
    Nov 16, 2009 at 17:31
  • I thought if you can get the virtualisation solution to work, you can just install the VPN stuff in there? Nov 16, 2009 at 17:41
  • Right, but VM is still kinda RDP'ish but very doable. :)
    – jms
    Nov 16, 2009 at 18:52
3

You may be able to use something like netcat or fwop to proxy the TCP connection - though be aware most anti-virus will flag both of those executables and probably throw a fit.

1
  • 1
    I was thinking something similar, I'll check this out when I have some more time.
    – jms
    Nov 16, 2009 at 17:30
1

Not unless you set up some kind of RDP proxy on your laptop.

The latest SecuRemote/SecureClient should work on Windows 7, although is not mentioned as officially supported on Checkpoint's site. Checkpoint needs to get on the ball with this one....

2
  • Is this 64bit and do you have a link handy? I've looked before but their site gives me high blood pressure.
    – jms
    Nov 16, 2009 at 17:29
  • Yeah, I hear you on the blood pressure thing... Let me look and see if I can pull out a link for you. I'll have to dig, though. It's been a little while......
    – squillman
    Nov 16, 2009 at 17:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.