11

When I user remote desktop to connect to a Window 7 Professional computer (using win7 pro RDP) it first prompts me for my password:

Windows Security logon prompt

after successfully authenticating there, it connects to the remote machine and prompts for my username and password again:

enter image description here

Is there any way to stop it prompting the second time? This second prompt only shows up when connecting to another windows 7 machine. When connecting to a server (Windows Server 2008 R2) this second prompt doesn't show up.

Note: removed domain and username info from the above images, a missing domain isn't the issue.

  • the following question does not solve the problem. It is disabled on this domain, and it effects the first prompt, not the second. superuser.com/questions/241605/… – alumb Feb 5 '14 at 18:41
  • Setup the Windows 7 box for Network Level Authentication? – Zoredache Feb 5 '14 at 19:22
  • 2
    Check current GPs affecting the workstations: "You can also specify that a user is prompted for a password when connecting remotely to an RD Session Host server by applying the Always prompt for password upon connection Group Policy setting. This Group Policy setting is located in Computer Configuration\Policies\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Security" – Ƭᴇcʜιᴇ007 Feb 5 '14 at 19:47
  • 1
    Also see: superuser.com/questions/604483/… – Ƭᴇcʜιᴇ007 Feb 5 '14 at 19:49
  • have you tried "use another account" on the first dialog and entering the exact credentials on the first screen that you are using on the second screen? – Tyson Oct 20 '14 at 6:40
3

There are 3 group policy settings to check:
(they were already mentioned in comments 1,2 above)

Remember to do gpupdate /force and check the actual values with rsop.msc.

If nothing works, consider using alternative RDP client, whith better logon automation:

Also take a look at the following Windows Feedback Hub item: normal or for windows insiders and consider up-voting it. There's a tiny chance that this would help as well.

PS. Here's yet another similar issue.

2

It can work to clear the credentials in the RDC connect dialog window and re-enter them. According to our server provider it is a common issue.

  1. Open you connect dialog.
  2. Select the computer you want to connect to.
  3. Click the little blue delete link underneath.

    enter image description here

  4. Re-enter and save you password and it should work.
0

Not reccomended, but you could always save your credentials in a RDP file.

  1. Open Remote Desktop Connection by going to the Start Menu
  2. In the search box, type Remote Desktop Connection,
  3. In the list of results, click Remote Desktop Connection.
  4. In the Computer box, type the name of the remote computer you want to connect to, click Options,
  5. Select the Allow me to save credentials check box, and then click Connect.
  6. You'll be asked for your credentials, and the Remember my credentials check box will be automatically selected.

The next time you connect to that remote computer, your saved credentials will be used automatically. To edit or delete your saved credentials, click edit or delete.

  • 2
    This effects the first prompt not the second. So doesn't solve my issue. – alumb Feb 5 '14 at 18:44
0
  • Start the program Run
  • Enter control userpasswords2
  • Advance tab, Secure Logon, uncheck Ctrl+Alt+Delete

I hope this will help.
BTW I can't check this as the policy disabled my rights to edit this option.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.