6

I have installed a new hard disk drive on my Acer Aspire 771. I made a USB recovery stick as well as recovery cd of the Windows 8 64 bit running on the former HD (which got corrupted, so no cloning possible).

After two days of struggling, I managed to get the recovery going, but it aborted at about 80 % of loading. As before, the system is not booting, and only the recovery disk helps me to get the command promt (all other repair options fail).

I tried to recreate the BCD, doing something like:

select vol 2 --> EFI
assign --> resulted in F: drive
select vol 3 --> Windows8_OS drive (471 GB)
assign --> resulted in G: drive
exit
cd /d F:\EFI\Microsoft\Boot\
bootrec /fixboot
ren BCD BCD.bak
bcdboot G:\Windows /l en-us /s f: /f ALL

to no avail, resulting in the mentioned error message

I also tried:

BOOTREC /FIXMBR
BOOTREC /FIXBOOT 
BOOTREC /REBUILDBCD

without success.

I'm getting into slight dispair...

Thanks for any suggestions.

2

The error message clearly states that "BCD Template" is not present (or cannot be read).

BCD Template is in \Windows\System32\Config folder.

bcdboot command uses it for recreating BCD on system partition.

The possible solution is to obtain a Windows 8/64-bit installation DVD or ISO image and do a offline repair using SFC command (use DVD or mounted ISO as source for all repair operations like bcdboot for example).

SFC will repair/recreate all Windows system files.

| improve this answer | |
  • does it need special syntax or do you just boot from installation/repair CD, go to the repair console and then SFC somehow know on which Windows installation to run on? – George Birbilis Apr 26 '16 at 11:29
  • sfc has options and parameters .. and help as every Windows utility ;) Surprisingly sfc only displays help ;) – snayob Apr 29 '16 at 4:46
  • 1
    to reply to myself, the offline (having booted from installation/repair disk) syntax is usually SFC /SCANNOW /OFFBOOTDIR=C:\ /OFFWINDIR=D:\WINDOWS if you use UEFI (the system boots from other partition than the one Windows is), but it might also be E:\WINDOWS for the windows directory (have to check each disk to find it, since booting from installation CD results in other drive letters than usual). In my case this still didn't help, SFC was failing for other reasons to work – George Birbilis May 2 '16 at 22:25
  • Example syntax and explanation of parameters - boyans.net/RepairWindows/… – snayob May 3 '16 at 3:57
  • This ends with Windows Resource Protection did not find any integrity violations. but i still cant boot. Back to 0x000000f – Dusan Bosnjak 'pailhead' Aug 2 '17 at 2:44
1

The error could be caused by running the command without administrator privileges. I found that running the command with administrator privileges fixed this error (at least for me).

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.