2

I've got a project I'm working on in SharePoint. I've mapped the SharePoint library to my computer and have been working on the files using sublime text 3. However, saving files in sublime is taking some time and cause the entire application to stall for a bit.

2 Answers 2

6

Go to Preferences -> Settings-User and add this line:

"atomic_save": false

This should significantly speed up network operations. See my answer over at StackOverflow for an explanation of what atomic save is. The question I answered shows how many disk/network operations can occur when atomic save is on, as it is by default in Sublime Text 3. ST2 does not have this option, and does not use atomic saving.

2
  • 2
    This saved me about 2 hours a week.
    – ZeWaren
    Apr 17, 2014 at 13:00
  • @ZeWaren - glad I could help!
    – MattDMo
    Apr 17, 2014 at 14:21
0

Its not related to Sublime, it's related to Finder if you're on a Mac and browsing files over SMB, at least in my case. Opening many files in Finder SMB caused high traffic which slows down Sublime. Try switching to AFP instead.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.