I have a Excel spreadsheet that is edited primarily from my desktop computer at work (which has two large screens) but is also sometimes edited on my personal laptop computer from home (which has one relatively small screen). The spreadsheet has a chart in it that looks fine on one of my large screens at work, but when I open the file at home, it runs off the edge of the page (as can be observed in the screenshot here).

I thought Excel took care of fitting the chart to the available space on its own, but evidently not (at least not in this case). I have tried zooming in and out and resizing the chart to try to trigger Excel's auto-resize, but nothing seems to work.

Does anyone know how to get the chart to fit the page it has been inserted into?

I am using Office 2010. Additionally, there are VBA macros the pull the data for the chart and make slight changes to it (i.e. plot order, line color, setting the horizontal axis to fit the data).

SU713448 question example


It looks like your chart sheet has been set to 80% zoom rather than "Fit selection".

At the very bottom of your Excel window is the status bar. Starting from the right of the status bar, there is a "+" symbol which you can click on to zoom in, then a slider which you can drag right or left to zoom in or out, then a "-" symbol which you can click to zoom out, then "80%". That "80%" is the current zoom magnification.

Click on the "80%" to open the Zoom dialogue box, select "Fit Selection" and click "OK". Now it should auto-resize with the window.

  • This is not the problem. In fact, this screenshot is zoomed out from what it was when I opened the workbook. Basically, the symptoms of the problem are that the chart is larger than the page. Zooming in and out changes both the chart and the page size at the same time. I have not been able to find a way to change the chart size independent of the page size. – tlewis3348 Feb 8 '14 at 23:01
  • @tlewis3348 in that case it's not something that I've seen before. Good luck! – Levi Feb 9 '14 at 18:05
  • This was the problem for me. I had forgotten about that option in that box. – RPh_Coder Dec 18 '15 at 19:42

Excel treats a Chart that has a dedicated worksheet as a page, so to change the size & proportions you have to go into Page Layout and adjust things like Margins, Orientation, and Size. It's an awkward UI requirement but it does the trick.


I took a brief look into this and you are not the only one that is experiencing this. Please type in the following google keywords and make what you may of the results.

Excel 2010 format size plot chart area greyed out disabled

  • -1, this answer appears to be a slightly more polite version of LMGTFY, which goes against the point of this site. Please see meta.superuser.com/questions/5642/… for more info. As for your answer, perhaps you could add some additional information to make it stand on its own, as an answer. – dav Feb 7 '14 at 13:00
  • Just thought I would help in providing perhaps a more concise way of searching for results. None the less I will refrain myself from giving slightly polite versions of LMGTFY answers in the future. Thanks – Linux NewB Feb 7 '14 at 14:51
  • No worries, I think you'll find that this site has a pleasantly strict manner for approaching Q&A. A few options include converting your answer to a comment (which are less formal and a good spot for some general guidance), or add additional detail and make it a full, stand-alone answer. – dav Feb 7 '14 at 15:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.