0

I have Seagate Barracuda 2tb hard disk which has been working happily in a NAS for a year or so. Unfortunately the disk now appears to be broken as the NAS doesn't recognise it.

I've tried plugging it into my laptop and desktop and both know its there in Disk Management but it appears as 'not initalized'. I believe initializing it will reduce my chances of recovering the data from it so I've not gone down that path yet. I've tried various tools such as MiniTool Partition Wizard, Partition Find & Mount and Easeus Partition Manager but none of them recognise the disk as being present so don't give me any recovery options.

I've also tried booting into Ubuntu just to see if that could see it, but alas no.

Can anyone suggest any alternative approaches I could take to getting it in any sort of working state? I'm a bit pessimistic given how it's gone so far, but maybe all is not lost.

  • You have tried the good tools and the alternatives you might have to accept the files can't be restored – Ramhound Feb 7 '14 at 20:20
  • Sounds like the partition table is toast, However, physically, the drive may be good. Corruption happens from time to time, Give it a good DBAN and use it in a non-mission-critical way. – Oxymoron Feb 7 '14 at 20:39
  • Have you tried testdisk? – txtechhelp Feb 7 '14 at 23:25
  • Hi, I tried testdisk in Ubuntu and just tried the Windows version - both behave as others, where the problem drive isn't even listed unfortunately – RichardB Feb 8 '14 at 0:13
  • If the disk is still visible on the BIOS, you may want to try Spinrite as there are lots of testimonials about how it manages to "resurrect near-death drives" so to say. – Darius Feb 8 '14 at 0:27
0

It's good to know the risks associated with DIY recovery software before you try it. (Read about the risks of DIY data recovery software).

You did the right thing in not initializing it, and the last thing you want to do is run Spinrite on a failing drive, as it will make it fail much faster.

If UBUNTU was not able to recognize it you probably have some sort of mechanical failure with a read/write head, some corruption in the firmware or service area. Seagate drives are notorious for this. The tools required to repair this run about 7k plus potentially a clean room.

If the data is important you might want to contact a professional company for help. SERT Data Recovery is a reasonably prices service with up front flat rates, and even pay for shipping in some cases.

  • Thanks @BillyData you've backed up my suspicion. I can hopefully live without the data, it was more the inconvenience of losing it all I was trying to avoid. I'll make sure I backup properly in future! – RichardB Feb 11 '14 at 13:50
  • It's a tough lesson to learn. But yes redundancy is the key to avoiding this situation altogether. – BillyData Mar 29 '14 at 19:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.