0

I am rather new to using Eclipse for working with Websites, so please if you need more information on what I am using just comment and I will edit it into the question.

I did all this fun stuff to get FTP functionality in Eclipse so that I could work on Website files on my host server.

one time this happened I got a NullPointer Exception but it didn't give me much information and never happened again.

I usually have to restart eclipse in order to save the files back to the FTP site again, as long as I don't leave the FTP connection idle it doesn't drop the connection and freeze.

everything else works except for communications across the connection. when I try to close eclipse, it tries to save the workspace but can't because the connection is fried and I end up with an application crash because of whatever exception is given.

can anyone tell me if this is something that they have fixed or if I am setting something incorrectly, or if there is a better IDE for writing code (PHP, HTML, CSS, Javascript, etc) that I can FTP to my host with?


I checked for updates (for Eclipse) and installed some, it works....better than it did before, but I tried to open a folder and it froze until the connection was broken, not sure why....


This is the Error Message that I get when I try to close the application and it can't save the workbench

Message reported from file system: java.lang.NullPointerException

I imagine this has something to do with the Frozen FTP connection


still having the same exact issue, except for this time, I was using the application, and then tried to save my work and I get a NOOP Message in the FTP Console and then I try to refresh the connection and it just runs and runs. I will have to restart Eclipse in order to save anything.

is there a better application for working on my websites (on Ubuntu)??


it is still happening on another website that I am working on, I just tried to close the application so that I could restart it in the hopes of working on the site again and when it was trying to save the workspace it returned an operation failed error

it says File system input or output error when I click on more details it says

Message reported from file system: java.lang.NullPointerException

2
  • Message reported from file system: java.lang.NullPointerException I imagine this has something to do with the Frozen FTP connection
    – Malachi
    Feb 8 '14 at 22:10
  • Ubuntu 12.10 upgraded to 13.10, no change. I assume that Eclipse is the Newest Version as of like a week ago, I just updated it to try to fix the issue, I will double check when I get home what version it is
    – Malachi
    Feb 18 '14 at 18:58
0

I think what is going on is that I was trying to use FTP more like a Remote Connection to the server instead of an actual FTP connection where I transfer files and then disconnect.

there is still the issue of this use crashing the FTP Functionality instead of just closing the connection.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.