Got a Windows 8.1 upgrade prompt. Clicked YES. Then laptop took long to download the upgrade. After a day, I assumed the upgrade was through as the laptop had rebooted. I powered on the laptop. It gave an error message about choosing a boot option. I guess similar to ""Reboot and Select proper Boot Device or insert Boot Media in selected Boot device and press a key_"

when I changed the boot config from Launch fast boot to launch CSM and also disabled Secure boot Control in the BIOS and hit the SAVE key.... it took time. So clicked again on Save and finally hit the Power button to Hard reboot the laptop. Since then the Laptop display is blank.

I have tried some of the tips... ex. remove laptop battery, reset the CMOS after removing the CMOS battery and keeping it away overnight, putting a coin in the battery compartment to discharge, reverse polarity of battery for a few seconds, pressing the power button for 45 sec after removing laptop batteries....removing RAM and putting it again in the same slot... I see the Power LED is On, I see the hardisk and other LEDs blink once and the system seems to want to start and then all is black. I have even removed the Hard Disk and tried to reboot. Still nothing displays on LCD display which is also brand new.

Any other options? Thinking of taking it to the ASUS service center. My laptop is out of warranty since Nov 2013.

  • is your screen blank by the time you press your power button? – Uğur Gümüşhan Apr 4 '15 at 21:03

Clearing the CMOS on your motherboard will reset your BIOS settings to their factory defaults.

There are a few ways to clear the CMOS on your motherboard, but the most common is to remove the CMOS battery and install it in the opposite way "upside down", "reversed". After clearing the CMOS, you'll need to access the BIOS setup utility and reconfigure your hardware settings.

This is considered a "hard reset" and helps recover from forgotten BIOS passwords, system hangs due to changes made to the BIOS, etc.

  • Clearing the CMOS did not work. Gave the laptop to ASUS Service Center who checked and reported that the Motherboard was bricked and needed to be replaced. I tried giving the laptop to a different service center since the warranty had expired 2 months back and this repair shop too could not fix the issue. They report that getting components/parts for ASUS laptops is next to impossible in the grey market which is not the case with HP, Dell, Toshiba etc. – Srini Feb 20 '14 at 11:37
  • 1
    I find reversing the battery strange. Would that not brick the motherboard? – Hennes Aug 8 '16 at 18:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.