1

I have an HP Elitebook 2530p http://h20565.www2.hp.com/portal/site/hpsc/public/psi/home/?sp4ts.oid=3782222

There is a common bios problem (I know I am not the only one who had this problem) that asks for a "Multibay drive Lock Password" on boot. It is a bug because A Drive Lock password was never set. The workaround is to pull out the Optical Drive(In my case, the secondary HDD) before powering on the computer.

After that, simply logging into the primary Hard Drive (SSD) and running HP's bios update.exe would solve everything.

However, I am missing my SSD, and by unplugging the secondary HDD before powering on the computer, (necessary for bypassing the password bug) I lost access to the HDD as well.

I have tried using HPs bios update .exe to creat a bootable usb of it, but my computer doesn't recognize it. It just says remove disk or other media and try again.

I know that my bios is set to boot from flash because I have successfully booted a live distribution of Ubuntu 13.04

So my only options (as I see them) are:

-Install Windows on an external HDD and run the bios update.exe

-Install a live image of windows onto a Flashdrive (since I don't have an Optical Drive) and run the bios update.exe

-Install a live version of DOS onto a flash drive and (somehow) update the bios from there

or

-boot into a live Linux distribution and find away to update the bio from that even though HP does not offer support.

I have tried many tutorials on all of the above with no luck.

The target computer I believe to be running Windows Vista Business (although I don't think it matters because there are no hard drives found)

The computer I am using to type this and download all of these tools and files for trying to solve this problem is a Samsung running Windows 7 Ultimate 64bit

I have spent the last few days trying to solve this problem, any help would be appreciated.

EDIT: I appreciate all the alternate solution attempts, but What I need is a way to flash the bios without an internal Hard Drive.

I have USBs I can use, if necessary, as well as External Harddrives.

  • Have you cleaned the contacts, both where your carrier fits into the multibay, and also where your HDD fits into the carrier? – Ben Voigt Feb 9 '14 at 23:58
  • No, as I do not have any tools to do that. The thing is, I can pull out the drive, but I cannot pull it all the way out, something is holding it in and i don't have the tools to take the whole laptop apart. – joe Feb 10 '14 at 0:00
  • That sounds like your problem. One or more of the pins that connect your HDD are disconnected, or even shorted, and that's changing the status reply during boot from "Ok" to "Waiting for unlock". Surely finding the right tools (generally a set of jewelers' screwdrivers) would have taken less time than "the last few days" – Ben Voigt Feb 10 '14 at 0:02
  • The fix is flashing the BIOS anyway. even if I could pull out the multibay and clean it, I'm afraid the bug would persist. – joe Feb 10 '14 at 0:04
  • 1
    Your model may/may not be capable of this but my HP's are. Copy the flash files onto a USB stick. Go into the BIOS and under the first menu there is a flash bios option. (At least on the models I have encountered). Pick the option it will read and flash the BIOS. – cybernard Feb 10 '14 at 0:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.