I am setting up a computer with a 42" touch-screen for public presentation of life-sensor data.

I disabled all hot corners in the pc settings and also in the properties window of the task bar, I disabled "When I point to the upper-right corner ...".

The charms bar and all hot corners have been disabled for the mouse, but I am trying to disable the charms bar for touch-screen too. None of the options I found while googling the internet disabled that bar for touch-screen.

Does someone know, how to disable the charms-bar on touch-screens?


Sounds like you need Kiosk Mode.

you can lockdown the device allowing the user to use only one application. ... The user can neither drag the application down to close it, nor the charms or any other shortcuts will work. In order to log out of the Kiosk Mode, you can hit the Windows key 5 times.

If you are using a desktop application, you can call System.EdgeGesture.DisableTouchWhenFullscreen to prevent access to the charms bar when the application is open.

| improve this answer | |
  • Thanks, I will check it out. I can't use System.EdgeGesture.DisableTouchWhenFullscreen as it is a web-application that runs in the browser (kiosk mode of chrome) – RononDex Feb 11 '14 at 8:31
  • The kiosk mode only supports only metro apps, no desktop apps? I would have to start chrome in kiosk mode and with a particular website defined. – RononDex Feb 11 '14 at 8:46
  • That is what it is designed for. Set it to start the modern UI for Chrome, and if you want to lock it down further, use one of the "Disable address bar" extensions for chrome (superuser.com/questions/652377/…) – Mitch Feb 11 '14 at 12:58
  • The problem is, that chrome is not a metro app and you can choose only metro apps for that kiosk mode. However I managed to achieve this by using the app "Kiosk Browser" which displays a predefined url with the IE. I can then select this app to run with a kiosk user. – RononDex Feb 11 '14 at 13:07
  • Chrome can be used as a metro app. Search the store or support.google.com/chrome/answer/2762879?hl=en – Mitch Feb 11 '14 at 13:17

Windows charms bar is operated by explorer.exe. So if your app can run without it then you can hack around it by first disabling the autorestart of explorer.exe via (run as administrator):

reg add "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon" /v "AutoRestartShell" /t REG_DWORD /d 0

Then the lines below represent my launch.bat - which works in the end as expected:

;; kill explorer (this disables all windows functionalities
taskkill /f /im explorer.exe

;; start your kiosk app - should block the batch execution (so explorer.exe doesn't get executed at the end)

;; after you close both the app window and the opened chrome window relaunch explorer.exe to give back the functionality to windows. Use start to make the cmd window disappear
start explorer.exe

I use the approach outlined above to let a keyboardless kiosk app run. Because with a keyboard you can still close the app with alt+f4.

| improve this answer | |
  • Thanks for your (late) answer :). This project is already finished and I am already working for a different company. We ended up using a kiosk app, which runs IE as a metro app in Kiosk mode. But might give this a try whenever I have to do this again ;) – RononDex Aug 26 '14 at 8:37
  • No problem. I just wrote it here because I've lost 6hrs yday on this issue, and since I've stumbled across your question as well and I wanted to post a possible solution to maybe help others :). Cheers – Matyas Aug 26 '14 at 8:46
  • This helped me. No need to have the start explorer.exe to have touchscreen input. – AWippler Jan 22 '15 at 1:12

As answered above, Kiosk Mode is one option. Another is that you can install a start screen replacement, like Start8 and set it to disable the charms bar and all hot corners.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.