0

I was on CentOS with KDE, and I accidentally pressed Ctrl+Alt+Esc, and then clicked the desktop, and the taskbar. Only the mouse pointer worked now. My short research showed that this is xkill, and it kills the process I've clicked on. There are some instructions on the internet, which would help me when either the taskbar, or the desktop is killed, but never both.

What makes everything even more difficult, is that it was at the student's computer centre of my university. I tried to power-off the machine, and turning it on again, but it just connects to the central server, sees that my old session hasn't been terminated, and asks me for the password. There were literally no other options availabe. When I enter it, there's again the black screen, with only the mouse cursor. Logging in from another machine, everything worked fine. The computer is reset tonight, and everything should work fine tomorrow.

Still, I really want to know how you would escape from such a situation. Desktop and taskbar are gone, Ctrl+Alt+F* doesn't work, and hard restarting only asks for your account password again, leaving you the session with the black screen.

4
  • You could try Ctrl+Alt+T and see if that opens a terminal prompt. Feb 11, 2014 at 3:37
  • Or Windows(Super)+T if that shortcut is setup.
    – Lawrence
    Feb 11, 2014 at 4:28
  • sorry, but they both don't work Feb 21, 2014 at 12:40
  • on Linux Mint, Ctrl+Alt+Del instantly exits your user session and starts it again, as if you logged out and back in. I don't know if that works with other distributions too.
    – xeruf
    Mar 3, 2018 at 1:43

1 Answer 1

1

If it's just a black screen, you make have only killed the KDE Plasma interface, leaving X still running. You can try to get to a virtual terminal with Ctrl+Alt+F1. Once there, you can use any manner of commands to get X restarted. One option is to go with:

restart X

Since you are running KDE 5, you might consider the following:

killall plasmashell
kstart plasmashell

To ensure the KDE plasma interface is dead before attempting to restart it. Once that is done, simply hit Ctrl+Alt+F7 or Ctrl+Alt+F8 to get back over to the terminal that X should be running on.

A more nuclear option would be to press Ctrl+Alt+F1 to get to a virtual terminal and then enter:

init 3

Wait a few seconds (maybe press Enter a few times) and then enter:

init 5

This should drop everything down to runlevel 3 (pre GUI) and then kick off all the processes for runlevel 5 (GUI / display manager running).

Hope this helps.

2
  • This might come in handy sometime, but for this problem, as already written, Ctrl+Alt+F* (* stands for any number here) did not work. (Disclaimer: I'm not any longer enrolled in that university for quite some time now, so I can't check anything I haven't tried yet.) - EDIT: I've just seen that KDE Plasma was introduced in July 2014, but this question is from February 2014. Jun 6, 2018 at 8:27
  • @user2009388 I missed that part of the question, sorry. I tried to at least cover all the eventualities with the service restart and runlevel restarting, at least. shrug Jun 6, 2018 at 13:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.