3

I have an MS Access 2007-2013 database (.accdb format) which I open in MS Access 2013. It has just one table with several columns

Lat          Long       PositionDate    
-54.82045   -68.33834   20130825    
-54.82018   -68.33854   20130827    
-54.81958   -68.33004   20130102    

My goal is to convert this MS Access table to a text file in comma separating format. I go to External data tab > Export section > Text file. I don't specify any export options and click OK. I choose the file to be Delimited > click Next > Choose Comma > click Finish.

However, in the result .txt file I get the lat and long fields rounded to two decimals. I have looked over cell settings in Access but with no success. How do I avoid this rounding?

-54.82,-68.33,"20130825"    
-54.82,-68.33,"20130827"    
-54.81,-68.33,"20130102"    
-54.81,-68.33,"20130202"
2
  • 1
    Have you tried changing the definition of the field from general to fixed with 5 decimal places? – Julian Knight Feb 11 '14 at 16:56
  • 1
    @JulianKnight, I have just tried this but it didn't help. – Alex Tereshenkov Feb 11 '14 at 19:29
2

As far as I know, the only way to change that (rather annoying) behaviour in Access is to open the "Regional and Language Options" in the Windows Control Panel, click the "Customize this format..." button on the "Formats" tab, then change the "No. of digits after decimal" value on the "Numbers" tab:

NumbersTab.png

2 is a very common default value. In the above dialog I have changed it to 5.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.