8

I'm running a server and sometimes one of my apps will crash which shows this dialog

enter image description here

This is annoying because it holds the process open until someone physically jumps on the box and presses 'Close the program'.

What I'm wondering is how I can disable this damn dirty dialog box on my server?

4
  • 5
    Uhh... Maybe you should find out why the program is crashing rather than trying to disable the crash notification?? When your check engine light goes out, unplug the dash?? Feb 11 '14 at 20:14
  • Check event logs for possible sources for the crash. AS noted, the popup is there for a reason.
    – Dave M
    Feb 11 '14 at 20:42
  • 4
    @HelpingHand The software is software I wrote. I expect it to fail sometimes, I just can't handle it gracefully when this box pops up. A program should be allowed to crash without a dialog box of all things popping up(such a bad idea, especially on a server). Also, the comments aren't really constructive or relevant to the question: 'Joe Schmoes best practices' wasn't what I was looking for. Feb 11 '14 at 20:46
  • @techie007 The program fully stopping is part of my over all process. Feb 11 '14 at 21:29
11

The registry way

There's no way like the registry way.

  1. Open an elevated command prompt.

  2. Type or paste the following command, and press Enter:

    reg add "HKLM\SOFTWARE\Policies\Microsoft\Windows\Windows Error Reporting" /v "DontShowUI" /t REG_DWORD /d 1 /f
    

Additional information

There is also a related, per-user DontShowUI value stored in HKCU\Software\Microsoft\Windows\Windows Error Reporting. Machine settings takes precedence over user settings, and changes are applied immediately.

For testing purposes you can use Bad Application:

[This tool] emulates a bad application. BadApp allows you to change its process priority, start an endless loop (i.e. "hang" or stop responding) and crash its process.


Using the Group Policy Editor

  1. Start gpedit.msc.

  2. Navigate to Computer Configuration > Administrative Templates > Windows Components > Windows Error Reporting.

  3. Double-click the Prevent display of the user interface for critical errors policy, and set it to Enabled.

At least Windows Vista.

This policy setting Prevents the display of the user interface for critical errors.

If you enable this policy setting, Windows Error Reporting does not display any GUI-based error messages or dialog boxes for critical errors.

If you disable or do not configure this policy setting, Windows Error Reporting displays the user interface for critical errors.

Source: Group Policy Search

4

I don't have a crashing program to test with on-hand, but give this a shot:

  1. Run gpedit.msc to open the policy editor.
  2. Navigate to Computer Configuration > Policies > Administrative Templates > Windows Components > Windows Error Reporting
  3. Enable the "Prevent display of the user interface for critical errors" policy.
1
  • Thank you this worked. Unfortunately I feel like I have to give it to the other dude, just because the quality of the answer. Thanks again for responding quickly. Feb 14 '14 at 22:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.