16

I'm having a slight delay (50-200 ms estimated) with keyboard input (code editing) from within Visual Studio 2013. The problem does not occur with Visual Studio 2010. When typing, there is a slight delay before the key displays on the screen. I don't know if this is something I can fix.

Here's some things that may narrow down the issue.

  • I've used msconfig to close programs.
  • I have a dual monitor setup, with 1920x1080 resolution on both (1700 MB total video memory according to dxdiag)
  • Using a laptop, quad-core i7, 8 GB RAM
  • Windows 7, 64-bit
  • Problem occurs in Visual Studio 2013 (Professional), code editing (including VS2013 safe mode) (meaning, don't mention plugins in your answer if you want a vote) - See https://msdn.microsoft.com/en-us/library/ms241278(v=vs.120).aspx for an explanation of what safe mode does.
  • Problem does not occur in Visual Studio 2010
  • Problem does not occur in notepad
  • Sometimes it can get worse if the computer has been running for days, restarting temporarily improves it (but still a bit more delay than VS2010)

Obviously Visual Studio 2013 is newer and has more bells and whistles, maybe one of these features creates some additional overhead involved with inputting code. Any ideas that could improve this will be helpful. I prefer solutions which are simpler, but I'll take what I can get.

  • 2
    I have the same issues. It was noticed immediately when going from VS2012 to VS2013, and my co-workers experienced this as well. Not only is there a delay in my code showing up, but it seems things no longer happen sequentially. A common pattern for me is control+f, control+v. That would paste into the find dialog in VS2012, but in VS2013 it pastes into the code editor prior to the find dialog showing up. When I notice, I press control+z to undo, but that ends up inside the find dialog because of the time passed. – Joseph Lennox Feb 26 '14 at 16:59
  • 1
    Does this thread help? – harrymc Mar 15 '14 at 10:20
  • I didn't know about that one, but no it did not make a difference in my case unfortunately. – Nuzzolilo Mar 17 '14 at 18:09
  • You need to check two things: CPU load and drive load. Open the Task Manager and observe the CPU load to determine if the problem is due to the CPU is being overloaded. Watch the HDD LED to see if it flashing rapidly or on and solid to see if the problem is due to the hard-drive is being thrashed (and thus overloaded). Both can cause this symptom. If you find either to be the case, then your next step is to figure out why the system is being burdened. – Synetech Mar 21 '14 at 16:51
  • In my case 0% cpu and 0% disk. But any text editing heavily lags? Must be due to some sort of plugin or something. – Zapnologica Mar 18 '15 at 5:12
12

I also experienced serious keyboard lag when typing with VS2013. For me, things got much better by uninstalling one particular plugin:

Tools --> Extensions and Updates -->  Uninstall Application Insights

I don't remember installing this plugin, but it's called Application Insights Tools for Visual Studio. The referenced page mentions that this extension is a preview, for what it's worth.

  • 1
    Do you know if this issue occurred in safe mode as well? – Nuzzolilo May 19 '15 at 23:48
3

I had same experience with VS 2013 ultimate.

It got much better when i disabled CodeLens feature.

(you can find it in Options -> Text Editor -> All Languages -> CodeLens -> uncheck Enable CodeLens)

2

I had this slow keystroke response issue when editing a Razor file (.cshtml), and with ReSharper active. There was a setting under the Code Editing group within the ReSharper options for Razor --> Context Actions. There are two checkboxes:

   _ Convert Razor Block markup to Line markup
   _ Convert Razor Line markup to Block markup

Both of them were checked, which did not make sense, so I unchecked them both. Then went back to editing the file, and voila - instant speedup on my typing!

  • Resharper is disabled in Safe Mode. This question specifically mentions that this behavior persists in safe mode. No vote given. – Nuzzolilo Oct 11 '15 at 23:17
  • There might be a bug in the saving of these settings. It tripped me up. Check you have the latest version of R# installed jetbrains.com/help/resharper/2017.1/… – cottsak Apr 20 '17 at 8:00
1

I had the same issue but when I went to close VS 2013 I received an error saying I needed to download the Microsoft SQL Server Compact 4.0. Well I went and installed it then restarted VS 2013 and it's running nice and smooth now.

0

Disabling Intellisense auto updating using "Disable Auto Updating" in Options -> Text Editor -> C/C++ -> Advanced solved the lag for me (in case of C/C++ files).

Also I noticed that using smaller files helped, before I found the above setting. The lag manifested only when editing the beginning or the middle of a long file. At the end of a long file there was no lag.

0

By and large, disabling additional displays (second or third monitor) had the most consistent results for fixing this for me. I don't know the exact process that causes the slowdown, but the machine has to do a lot of extra processing to output to multiple displays.

With my home desktop PC with a Geforce GTX 980 Ti, this is not a problem. But most standard machines will include the subtle lag with multiple displays.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.