I know there are many topics, all with same problem, but all the answers seem irrelevant.

I have a ftp server/site and I am trying to map it to a drive in Windows 7...

Whatever I type as FTP address it says that path in invalid. For the particular test from the image, I had no problem logging to that ftp server with Filezilla in 5 seconds setup. But this seems like an overwhelming task for Windows 7. Any ideas? I am hoping someone can point a bug and a patch/fix, because it looks like a bug.

The folder you entered does not appear to be valid. Please chose another.

That service that people talk about (Web Client) is started, if that matters.

Edit: when I view examples is mentions: ftp://ftp.microsoft.com and if I type exactly that, it instantly says that it is an invalid path.

sample error image

  • Is there a share for the FTP? Is it really using FTP or simulating FTP? Feb 12, 2014 at 1:59
  • Have you tried mapping a subfolder? Also, that IP is the same IP that I assign my desktop computer. Halo fan? Feb 12, 2014 at 2:07
  • @AthomSfere I can see the folders when I login with Filezilla, is that what you meant by having "shares" on the FTP ?!
    – adrianTNT
    Feb 12, 2014 at 2:42
  • The problem seems to be a bug in windows, when I view examples is mentions: "ftp.microsoft.com" and if I type that it instantly says that it is an invalid path.
    – adrianTNT
    Feb 12, 2014 at 2:43
  • ftp.microsoft.com is an invalid path... What I meant earlier is you don't generally share the machine root as anything. A share is generally \\ipAddressorHOST\ShareName for example, many times you will do an FTP share the same, server/ftpFolder and use DNS to direct from there. But... What OS is the FTP server running also? Feb 12, 2014 at 2:45

3 Answers 3


Enable NTLM Authentication: Most obvious or probably answer to me.

Open regedit and navigate to:


Once there, right click the Lsa key and click new --> DWORD. Name the DWORD LmCompatibilityLevel and set the value to 1

Close all open browsers and then try again to access the FTP share.


Have you tried flushing the ARP cache? It's an unlikely, but possible, cause. Open an administrator version of cmd.exe and run this string: "netsh interface ip delete arpcache"

edit: and then try adding the location again. Irrelevant, the OP already contacted me directly.

Update: Are you checking the ""Connect using different credentials" box? And are you being prompted for the login info, or does the error appear immediately upon clicking "Finish"?

  • 1
    And then do what? This appears to be a comment, not an answer. Feb 12, 2014 at 2:47
  • @apraetor no, it doesn't seem to help.
    – adrianTNT
    Feb 12, 2014 at 2:50

Found the fix on different thread, resolves the issue

I found a fix on this website: http://social.technet.microsoft.com/Forums/en/ieitprocurrentver/thread/3d74bc03-b0c4-4ec1-88df-b938ec82c159

Many thanks to TerkildHolst who had the solution for Windows 7! It seems that Google Chrome causes this problem. To fix, copy the following bold text. Save it to a text file. Change the text file name to ftp.reg. Double click the file and voila!

Windows Registry Editor Version 5.00
@="URL:File Transfer Protocol"
"Source Filter"="{E436EBB6-524F-11CE-9F53-0020AF0BA770}"
"URL Protocol"=""
  • You really should provide proper formatting to this answer. You should also quote and cite your reference link. Anything not within a quotation block is assumed to be your own original words. Its clear from your answer that isn't the case.
    – Ramhound
    Jan 24, 2017 at 15:11
  • Please read How to reference material written by others. You should block quote text that has been written by some else. See Markdown help. I've fixed it for you this time, but please pay attention to this in future.
    – DavidPostill
    Jan 25, 2017 at 23:34
  • @Walmart Fixed. There is a very intermittent error in SOUP which breaks the links inserted by AutoReviewComments. My original source is correct until it is pasted :/
    – DavidPostill
    Jan 25, 2017 at 23:38
  • @DavidPostill Ah, I see... I didn't know about that tool, looks interesting though. I'll check it out someday if I ever get some time!! Jan 26, 2017 at 1:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .