6

The auto brightness "feature" of Windows 8.x is driving me crazy. I would like to switch it off on my Lenovo W530.

  • Adaptive Brightness is disabled in Power Options
  • the Sensor Monitoring Service is stopped and disabled
  • I checked all entries in the nVidia manager but found nothing related

Has anyone managed to disable this feature from hell?

UPDATE: following the discussion in the comments, I want to make clear that I do not want to disable automatic dimming to a preset level after a given time (which is useful). I want to disable the feature which dims the screen in and out whenever there is a perceived change in the ambient luminosity, or when I open a large dark window.

  • Are you using Windows 8 or 8.1? What are the Dimmed Display Brightness values set to in the Power Options? – and31415 Feb 12 '14 at 14:34
  • @and31415: I am using 8.1. The values for "Dimmed display brightness" are 50% for each case. Does it matter for adaptive brightness? – WoJ Feb 12 '14 at 15:23
  • Set both to 100%. Also, make sure Dim Display After is set to 0 (never). – and31415 Feb 12 '14 at 15:43
  • 1
    @and31415: wouldn't that completely disable dimming? (I need it particularly when on battery). Dimming itself is not a problem - it is the adaptive feature which is. – WoJ Feb 12 '14 at 15:54
  • Sorry, I was not clear. I would like to screen to dim automatically to a preset value when not used (as it has always done) -- I do not want it to dim in and out frantically whenever there is a change in ambient luminosity, or when I open a dark window on the screen. – WoJ Feb 12 '14 at 16:00
2

Yup, I know what you mean, and I did a search on my X220 before, here is the soluation:

Uncheck Display Power Saving Technology in Intel Graphic and Media Control Panel then you are good to go enter image description here

  • Thank you! You saved me a ton of frustration! On my 2017, Win 10 Thinkpad, you can find it by searching for Intel® Graphics Settings. – msysmilu Nov 20 '17 at 22:39
  • This should be the accepted answer. – msysmilu Nov 20 '17 at 22:40
-1

I had a similar problem on my girlfriend's new laptop. You said you've checked all your Nvidia settings, but do you also have some integrated system Intel graphics? In that case, go check the Intel graphic card settings and make sure that "Power saving technology" is switched OFF! That made the job for me!

  • 1
    I have just one (integrated) Nvidia card. I saw various posts about the same issue with Intel cards, but unfortunately I do not have any. – WoJ Feb 23 '14 at 19:13
  • This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post - you can always comment on your own posts, and once you have sufficient reputation you will be able to comment on any post. – Ramhound Sep 28 '15 at 15:18
-1

I don't know if you still have the problem since the post is pretty outdated, on my Lenovo w530 (equipped with NVidia Quadro K1000M) from NVidia Control Panel choose "Adjust Video Colour Settings", select "With the NVIDIA settings", Advanced Tab, choose "Full (0-255) as Dynamic Range and be sure Dynamic contrast enhancement and Colour Enhancement are turned off. Apply, RESTART (it does not change until you reboot). Hope it works!

  • This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post - you can always comment on your own posts, and once you have sufficient reputation you will be able to comment on any post. – Ramhound Sep 28 '15 at 15:18

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.