1

This is what I want:

I have a German keyboard layout (physical and well as set up as such in Windows), am mostly writing English in Office applications like Word and OneNote, and would like to set the spell checker to British English.

This is what I get:

Having a German keyboard layout set up, my default input language is implicitly German. Each newly typed word is interpreted by the spell checker as German, even after I set the proofing language to English (either by selecting all existing text (Control + A), or without any selection when cursor is at the end-of-text position); I have to set the spell checker after every word manually to English.

In a couple of Microsoft Office's online support articles (such as this one), the following is stated:

Microsoft Office uses the default input language in the Windows operating system to determine the default language for Office programs.

My concrete question is:

Is is possible to deactivate this coupling, and to set a default language that is different from the Window's input language. (Any hack is welcome ;-))

Potentially related question on superuser:

Update:

A workaround that works good for me has been suggested at related question no. 2.

1

Yes, I do it a lot because I work in eleven languages (I don't understand them all of course). Go to "Start" and run "Microsoft Office 2010 Language Preferences".

Here you can configure all installed languages for spelling checker and user interface of Word. You might need to acquire additional languages.

| improve this answer | |
  • Thanks, @Guido. That is the ordinary way of changing the "proofing language", which I tried as my first guess. But it doesn't work. In fact, I am looking for a way to make exactly that work: to set the proofing language within an office application rather than having Windows overruling this setting. Maybe, that was not very clear from my question. Therefore, I added "even after I set the proofing language to English" to point out that the ordinary way is NOT working. – Fatih Gey Feb 12 '14 at 15:14
  • Hi @Fatih Gey, I can't reproduce this. I've tested on my server and once set proofing language with office app, it stays that way (with some irritating bugs replacing proofing language in powerpoint, but there is an add-in for that). I've tried with Dutch, English and Italian. My keyboard is US International and configured as such. What might make the difference is that I'm running Office 2010 and 2013, but not Office 2007. Did you try it on Office 2010? – Guido Leenders Feb 12 '14 at 17:37
  • My bad, your right. In Word 2010, this works as expected. OneNote 2010 seems to be the ill child for me. Have you tried it there? – Fatih Gey Apr 23 '14 at 9:45
  • Hi @FatihGey, I've tested it. OneNote really works weird and different from other Office apps in this regard. I've switched to the German user interface and the ribbons are German, but the spelling check is Dutch and the samples are also Dutch, because I've started it once in the past with Dutch language. Maybe you can drop all existing notebooks (make backup), switch to English (in your case) and go through the initial steps again? – Guido Leenders Apr 23 '14 at 11:16
  • I have to retract my previous comment. Word 2010 and OneNote 2010 behave similar: Spell checker is for any newly written word set to German. In Word, this can be worked around easily my marking all (including the last white space character). Because the last white space somehow represents the formatting of the yet unwritten content, proofing language is automatically set for the text to come. In OneNote, this trick works only within one text box, but, as boxes are disconnected, not for the entire page. Creating a new OneNote file didn't help. – Fatih Gey Apr 25 '14 at 7:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.