9

You can connect to shared VMs running on VMWare Workstation 8 if you configured your VMWare correctly. Host and client are both Windows 7.

One disadvantage of shared VMs is: The clipboard feature gets disabled for security reasons.
I don't care about security in this case. There are no sensitive data.

Is there a workaround or a trick to re-enable the clipboard for shared VMs?


What I've tried

I added the following parameters to my VMX file as it's suggested for VMWare vSphere.
But it doesn't work for VMWare Workstation. (VMWare tools is installed)

isolation.tools.copy.disable = "FALSE"
isolation.tools.paste.disable = "FALSE"

Can anyone help?

  • Did you ever discover a fix for this? Just came across this problem myself. – Index Jan 22 '15 at 14:44
  • @KGChristensen No, sadly. – nixda Jan 22 '15 at 17:23
  • Does it works to share clipboard between host OS and guest OS, installing Guest Addition (probably setting bidirectional and restarting them)? If needed give a look to this answer and its references – Hastur Sep 7 '15 at 12:19
0
  1. Have you installed VMware Tools on the guest vm?

  2. Does other VMware Tools functionality appear to be working?

    • Can you - when your VM is in windowed mode - drag and drop a file from your host onto the problem VM?
    • Can you confirm there are two 'vmwaretoolsd' tasks running in the Windows Task Manager? One for SYSTEM user, one for your current user? You may need to click 'show tasks for all users'.
  3. Is there any antivirus software running on the guest vm? If so, can you disable it and test again?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.