This happens on one of my users Mac laptop running ML or Mavericks. When she accesses https://www.somewebsite.com using either Chrome or Safari, she always got the warning related to the certificate and Chrome gives her the red cross beside the word "https". But when we viewed the certificate information, it says the certificate is valid and verified by Thawte DV SSL CA.

It does not happen to my machine or another machine I tested. It does not happen to Firefox. Chrome is updated. We tried resetting Chrome and clearing all browser data. But it did not help.

I feel like it's something to deal with the Mac OS Keychain. I tried downloading my cert and have her import to her Keychain but that did not help either.

Any idea? Thanks much!

I had a similar issue recently and I needed to import an intermediate certificate on my server to have a valid chain.

Make sure your certificate authority doesn't require the use of an intermediate certificate.

Wikipedia reference: Intermediate certificate authorities

Your certificate authority (Thawte) reference: Downloading Intermediate CA bundle for SSL123

Please Note: On June 27th, 2010 Thawte upgraded its root hierachy to 2048bit RSA Keys to enhance the security of all SSL products. As a part of this upgrade, all newly issued certificates now require the installation of the new Primary and Secondary Intermediate CA's along with your SSL certificate. These new Intermediate CA's MUST be installed in order for your SSL certificate to be fully trusted in all browsers.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.