I am having trouble with my fan on my Lenovo thinkpad laptop. I have installed lm-sensors and ran sensors-detect and also added option fan_control=1 as a module parameter. The issue is two-fold.

First, I don't think my fan is detected at all. The reasons:

  • running sensors gives the following output:

    Adapter: Virtual device
    temp1:        +29.8°C  (crit = +100.0°C)
    Adapter: ISA adapter
    Physical id 0:  +41.0°C  (high = +87.0°C, crit = +105.0°C)
    Core 0:         +41.0°C  (high = +87.0°C, crit = +105.0°C)
    Core 1:         +38.0°C  (high = +87.0°C, crit = +105.0°C)
    Adapter: ISA adapter
    fan1:           0 RPM
    Adapter: Virtual device
    temp1:        +41.0°C  

As you can see fan1 = 0 RPM (this never changes)

  • running cat /proc/acpi/ibm/fan gives the following output:

    status:     enabled
    speed:      0
    level:      auto
    commands:   level <level> (<level> is 0-7, auto, disengaged, full-speed)
    commands:   enable, disable
    commands:   watchdog <timeout> (<timeout> is 0 (off), 1-120 (seconds))

"Speed" is always 0.

  • trying to manually change the level of /proc/acpi/ibm/fan does not have any effect. Level 0 and Level 7 are basically the same.

Secondly, if I assume that my fan is detected (and control works), there is the problem that once it starts running - it never stops (even when temps are low). I tried installing thinkfan, controlfan and other apps, but it still doesn't change anything.

I would like to point out that I have a hybrid GPU system, but I am using bumbleebe, so I only use the nvidia card when I run optirun <app>.

Any help will be appreciated!

  • Confirming issue on ThinkPad Edge E520 with Ubuntu 14.04. However, the fan works as expected when dual-booted to Windows 7. – ace Jan 6 '15 at 19:51
  • what happens when you run it fullspeed? – soandos Jan 6 '15 at 20:02
  • Have you checked for a BIOS update and whether the chipset driver is the right one for the computer? – harrymc Jan 7 '15 at 18:23
  • Same issue here. E530 + Ubuntu 14.04. Does anyone have a solution? – kontextify May 10 '16 at 8:57

Not necessarily may work here, but when I worked for DELL, most of the issues like that was solved installing OMSA package. It then caused Linux to miraculously find AGAIN hardware that was there before update, but missing after.

So my suggestion would be to look for something related to overall hardware detection problems on vendor site?


I think I had a similar problem and I solved it by:

# modprobe thinkpad_acpi fan_control=1

After doing that. What happens when you:

# echo "level full-speed" > /proc/acpi/ibm/fan

I am using thinkfan in a Lenovo Thinkpad x201 and it works fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.