0
  • echo $PATH gives me below result :

/home/mayank/bin:/usr/lib/lightdm/lightdm:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/lib/jvm/java-7-oracle/bin:/usr/lib/jvm/java-7-oracle/db/bin:/usr/lib/jvm/java-7-oracle/jre/bin:/usr/lib/oracle/12.1/client/bin

  • echo $ORACLE_HOME fetches :

/usr/lib/oracle/12.1/client

  • echo LD_LIBRARY_PATH gives (set through /etc/bash.bashrc)

/usr/local/lib

doing vim for .bash_profile shows below things set :

[[ -s "$HOME/.rvm/scripts/rvm" ]] && source "$HOME/.rvm/scripts/rvm" #
Load RVM into a shell session *as a function*

LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/local/lib
    export LD_LIBRARY_PATH

PATH=$PATH:/usr/local/bin
    export PATH

Despite setting the ld_library_path in above file I'm still not getting the correct path in env despite running sudo ldconfig and then rebooting my machine!!

what help I'm looking for :

  • set env vars correctly

  • run sqlplus

I have been a linux user for very short time...so don't exactly know the workaround...if you can guide me, I'll be grateful!!!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.