29

How can I map the keyboard shortcut to locking a session in KDE 4?

  • 3
    did you notice it defaults to ctrl+alt+l ? – Capi Etheriel Jan 18 '10 at 14:08
  • @CapiEtheriel -- Some of us work on more than one OS and would like to unify the keyboard shortcuts so we can be more productive. – Josh M. Mar 20 '19 at 13:58
38

Here's what you could do to remap session locking from default Ctrl+Alt+L (tested with KDE4.3) :

  1. Go to "System Settings" (KDE menu).
  2. Choose "Keyboard & mouse" (on "General" tab).
  3. Choose "Global Keyboard Shortcuts" on the left.
  4. Choose "Run Command Interface" from "KDE component" dropdown list.
  5. Choose "Lock session".
  6. Select "Custom".
  7. Click on "None" (button changes to "Input...").
  8. Compose your desired sequence by pressing appropriate buttons on your keyboard.
  9. Click "Apply".
| improve this answer | |
  • 2
    Keep in mind that this implies that SUPER is registered as a modifier key and not a key of it's own. – MiffTheFox Nov 17 '09 at 16:29
  • 7
    As of KDE 4.10.2 (Kubuntu 13.04): System Settings -> Shortcuts and Gestures -> Global Keyboard Shortcuts -> The KDE Session Manager -> Lock Session. – preds May 3 '13 at 0:25
  • You can also get to the Global Keyboard Shortcuts window by opening up the application launcher (kickoff) and typing "global keyboard shortcuts" into the search box. – rmiesen Jun 20 '13 at 19:08
11

In Kubuntu 14.04 it's

  • System Settings (from the Kickoff "Start" menu)
  • Shortcuts and Gestures
  • Global Keyboard Shortcuts
  • KDE Component: The KDE Session Manager (at the bottom of the list, scroll down)
  • Lock Session
| improve this answer | |
4

Kubuntu 18.10:

  1. System settings
  2. Search for "shortcuts"
  3. Global shortcuts
  4. ksmserver
  5. Lock session
| improve this answer | |
  • 1
    This is it right here -- thanks! – Josh M. Mar 20 '19 at 14:03
1

I imagine that man xmodmap will help with the keybinding part of it.

I don't know enough of KDE to help with what keysequence already locks the screen.

| improve this answer | |
1

default Ctrl+Alt+l did not work for me, maybe overshadowed by some other app - I had to explicitly set the shortcut as mentioned in the selected answer.

Also beware not to select "kscreenlocker", but the KDE session manager. Win/Meta+L worked fine here.

| improve this answer | |
  • Users coming from Windows expect Winkey+L to work. – Rich Sep 19 '18 at 19:25
1
  1. System Settings
  2. Shortcuts and Gestures
  3. Global Keyboard Shortcuts
  4. KDE Component: ksmserver
  5. Lock Session
| improve this answer | |
1
  1. Go to "System Settings" (KDE menu).
  2. Workspace>Workspace Behavior>Screen Locking>Activation>Keyboard shortcut or search "lock"
| improve this answer | |
0

In Debian 10 KDE Plasma it's:

  • System Settings (from menu)
  • Shortcuts
  • Global Keyboard Shortcuts
  • ksmserver
  • Lock Session
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.