17

I've tried these instructions to run Chrome in kiosk mode:

  1. Open up Chrome's settings.
  2. Under "Users" click "Add new user."
  3. Give the new profile a name and picture. Make sure "Create a desktop shortcut for this user" is checked. Click "Create."
  4. Right-click the newly-created shortcut and select "Properties."
  5. In the "Target" field, add "--kiosk" (no quotes) to the end.
  6. Click "Apply."

However, it doesn't seem to work for me; I still see tabs at the top of browser when I launch.

How can I launch Chrome in kiosk mode on Windows 8?

  • Did you set chrome to your default browser? This is Windows 8.1 right? – Ramhound Feb 13 '14 at 15:52
  • If it is not required to use Chrome as your browser, you can get the result you want in Internet Explorer: iexplore -k <page>. This works even if other Internet Explorer pages are open. (I don't normally recommend IE, but in this case kiosk mode works as desired, unlike Chrome) – yosh m Jun 22 '17 at 14:35
20

You should just add a starting page like this:

--kiosk "http://www.google.com"

if that doesn't work try this:

--chrome-frame  --kiosk "http://www.google.com"
  • 8
    When you have background apps enabled, you have to shutdown Chrome completely before mode change. Right-click on bottom right icon on a Windows status bar and click Quit. – Xdg Apr 24 '14 at 6:41
  • 2
    The above instruction works but only after you shutdown every single other Chrome that is up and running. The next restart would run in the kiosk mode. – Will Jan 23 '15 at 3:56
  • 1
    @Will chrome://restart – Blowsie Apr 5 '16 at 11:47
4

I create a shortcut on my desktop for chrome and then right click and choose properties.. in the "target" box, I add this:

"C:\Program Files (x86)\Google\Chrome\Application\chrome.exe"  --kiosk --kiosk-printing "https://google.com/"

here is the breakdown:

--kiosk 

(makes it full screen on load)

--kiosk-printing

(makes the system auto print the default print setting when you click print - no asking the customer to click the print button)

and the URL at the end is the homepage onload you want to launch with everytime

pops ups MUST be "allowed" using a normal browser window first (otherwise you don't see the error) so be sure to force the website to pop before going full kiosk mode. Clicking allow always will solve this future issue.

and the biggest problem is that you MUST force chrome to NOT run in the background, otherwise the full screen never kicks in.

right-click the chrome icon in the systray (by the clock) and UNCHECK "allow chrome to run in the background"

and then to close the full screen (besides alt-f4) i use this close kiosk chrome plugin: https://chrome.google.com/webstore/detail/close-kiosk/dfbjahmenldfpkokepmfmkjkhdjelmkb

the call for this plugin to kick in from a button onclick is:

window.location.href = '/closekiosk';

I hope this helps... I use kiosks for all of my public functions and the web is so much better than a crappy app.. easily fixed and managed. good luck!

  • You've not really added anything that answers why this isn't working for the user. – djsmiley2k Mar 23 '17 at 13:54
  • i did.. "and the biggest problem is that you MUST force chrome to NOT run in the background, otherwise the full screen never kicks in." – Teddy Mar 23 '17 at 18:54
2

you MUST force chrome to NOT run in the background, otherwise the full screen never kicks in.

right-click the chrome icon in the systray (by the clock) and UNCHECK "allow chrome to run in the background"

then the full screen shortcuts will work!

  • Teddy is right. Before using your new shortcut, terminate all open Chrome processes, either gracefully or using Task Manager. – user477799 Mar 23 '17 at 21:11
1

Anyone looking to do this on a local HTML file, create a shortcut to your Chrome executable, right click it, select "Properties" and then make sure the target field looks like this (for example):

"C:\Program Files (x86)\Google\Chrome\Application\chrome.exe" --kiosk "file:///C:/Users/JohnDoe/Desktop/MyHTMLFile.HTML"

The executable must be in double quotes, as well as the file path.

0

Chrome supporting background apps, for example you might have a background VPN tool working in background. Check hidden icons next to clock for windows then close it, should work.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.