7

Windows 7 Enterprise SP1 x64

I was having problems mapping a local drive to a network shared folder, so I opened cmd.exe and ran :

> net use
> System error 50 has occurred
> The request is not supported.

I've Google'd this extensively and apparently a lot of people have this problem, but very few have found solutions.

I investigated some of root causes others uncovered , such as mangled registry key values at :

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\NetworkProvider\HwOrder

How can I further diagnose this issue ?

What could have caused a very basic system-level command such as net use to begin failing ?

but in those respects my system seems to be fine

migrated from serverfault.com Feb 13 '14 at 21:20

This question came from our site for system and network administrators.

  • Is the network shared folder a Samba or a Windows share ? Also, is your machine a member of a domain ? – user2196728 Feb 13 '14 at 1:52
  • I've looked around the net a bit, and it looks like part of your networking stack is corrupted. Time to reimage/reinstall/reformat. – HopelessN00b Feb 13 '14 at 12:57
  • The network shared folder I was attempting to connect to is Windows Server 2008 R2 Standard. But my understanding of net use is that it should list all shares. In the case when there are no shares, it should display a message no entries in the list. – BaltoStar Feb 13 '14 at 19:01
  • @BaltoStar That's correct. net use by itself should return a "table" listing the mapped drives, or something like the image here, if there are none. Like I said, it's time for you to reimage/reinstall/reformat. – HopelessN00b Feb 13 '14 at 20:17
4

Start regedit.exe, and change the ProviderOrder value in the following registry keys

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\NetworkProvider\HwOrder
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\NetworkProvider\Order

from ,,RDPNP,LanmanWorkstation,webclient to RDPNP,LanmanWorkstation,webclient.

Source: To map Network Disk in Windows 7 error — SOLVED

  • 3
    For me, this issue showed up after installing SSHFS, and the keys looked like: "RDPNP,LanmanWorkstation,webclient,Dokan". I removed the ",Dokan", and it worked. But, I assume, SSHFS is borked now. – Codex24 Feb 24 '16 at 16:13
  • 1
    This fixed my problem with win_sshfs as well. I ended up uninstalling it and still had to fix the registry key. It just wasn't worth the freezing when accessing disks. – Mark Jan 5 '17 at 17:58
  • @Codex24 this regarding the dokan used by win-sshfs was quite the catch. but I still need to use win-sshfs. bummer – nass Oct 15 '18 at 9:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.