0

I am trying to stream my webcam feed through my Network but the receiving client cannot view and get the error: "VLC is unable to open the MRL." I tried to follow the instructions from here.

I tried doing it locally with the Windows 7 Enterprise firewall turned off using HTTP as destination. I created the stream using the destination of HTTP on port 8082 and checked on "Display locally". I set the http port to 8082. I can see my camera feed here fine.

I opened another instance of VLC to view the stream and pointed to http://127.0.0.1:8082, but get the error message: "VLC is unable to open the MRL 'http://127.0.0.1:8082'. Check the log for details."

Looking at Messages (verbose 2) debug window displays the following:

main debug: processing request item: http://127.0.0.1:8082, node: Playlist, skip: 0
main debug: resyncing on http://127.0.0.1:8082
main debug: http://127.0.0.1:8082 is at 1
main debug: starting playback of the new playlist item
main debug: resyncing on http://127.0.0.1:8082
main debug: http://127.0.0.1:8082 is at 1
main debug: creating new input thread
main debug: Creating an input for 'http://127.0.0.1:8082'
main debug: using timeshift granularity of 50 MiB, in path 'C:\Users\01roc1\AppData\Local\Temp'
main debug: `http://127.0.0.1:8082' gives access `http' demux `' path `127.0.0.1:8082'
main debug: creating demux: access='http' demux='' location='127.0.0.1:8082' file='\\127.0.0.1:8082'
main debug: looking for access_demux module matching "http": 12 candidates
main debug: no access_demux modules matched
main debug: creating access 'http' location='127.0.0.1:8082', path='\\127.0.0.1:8082'
main debug: looking for access module matching "http": 20 candidates
access_http debug: querying proxy for http://127.0.0.1:8082
access_http debug: no proxy
access_http debug: http: server='127.0.0.1' port=8082 file=''
main debug: net: connecting to 127.0.0.1 port 8082
qt4 debug: IM: Setting an input
main warning: connection timed out
access_http error: cannot connect to 127.0.0.1:8082
main debug: net: connecting to 127.0.0.1 port 8082
main warning: connection timed out
access_mms error: cannot connect to 127.0.0.1:8082
main debug: no access modules matched
main error: open of `http://127.0.0.1:8082' failed
main debug: dead input
main debug: changing item without a request (current 1/2)
main debug: nothing to play
qt4 debug: IM: Deleting the input
main debug: processing request item: http://127.0.0.1:8082, node: Playlist, skip: 0
main debug: resyncing on http://127.0.0.1:8082
main debug: http://127.0.0.1:8082 is at 1
main debug: starting playback of the new playlist item
main debug: resyncing on http://127.0.0.1:8082
main debug: http://127.0.0.1:8082 is at 1
main debug: creating new input thread
main debug: Creating an input for 'http://127.0.0.1:8082'
main debug: using timeshift granularity of 50 MiB, in path 'C:\Users\01roc1\AppData\Local\Temp'
main debug: `http://127.0.0.1:8082' gives access `http' demux `' path `127.0.0.1:8082'
main debug: creating demux: access='http' demux='' location='127.0.0.1:8082' file='\\127.0.0.1:8082'
main debug: looking for access_demux module matching "http": 12 candidates
main debug: no access_demux modules matched
main debug: creating access 'http' location='127.0.0.1:8082', path='\\127.0.0.1:8082'
main debug: looking for access module matching "http": 20 candidates
access_http debug: querying proxy for http://127.0.0.1:8082
access_http debug: no proxy
access_http debug: http: server='127.0.0.1' port=8082 file=''
main debug: net: connecting to 127.0.0.1 port 8082
qt4 debug: IM: Setting an input
main warning: connection timed out
access_http error: cannot connect to 127.0.0.1:8082
main debug: net: connecting to 127.0.0.1 port 8082
main warning: connection timed out
access_mms error: cannot connect to 127.0.0.1:8082
main debug: no access modules matched
main error: open of `http://127.0.0.1:8082' failed
main debug: dead input
main debug: changing item without a request (current 1/2)
main debug: nothing to play
qt4 debug: IM: Deleting the input
0

and checked on "Display locally"

uncheck this and you get your goal

0

Try putting in the name of the file for the stream - smth like videostream.asf after the IP of the camera like:

> http://127.0.0.1/videostream.asf

I do not know ig you are using GUI of CLI, but of it is GUI adding the name of the file should prompt you to enter password and user name in a new pop up window. With CLI is is a bit more trickier....

  • I am not playing a file it is a live stream. – Rick Jul 2 '14 at 23:36
  • it is the file for a livestream – also Jul 4 '14 at 14:27
  • coolutils.com/formats/asf – also Jul 4 '14 at 15:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.