I've installed Debian testing from netist image in a AMD Radeon system. I am using Xorg and awesome wm. The default screen resolution is 1024x768 while my screen supports 1366x768. I've tried xrandr and fglrx but they failed. The proprietary ATI drivers however solves this problem but gives a slow scroll effect. I've also used crunchbang linux and it displays the corect resolution without a xorg.conf or ATI drivers. Please help

  • 2
    It might help if you give versions of all the software you're using. Have you tried using amdCCCle with the proprietary drivers installed to tweak settings? – Ash Feb 14 '14 at 10:44

I have never seen xrandr failing at setting up even the most exotic monitor resolutions, but I have seen it misused very often. I'll post the exact sequence of commands for xrandr. If you have followed the same steps please ignore my answer.

  1. Use cvt to calculate the parameters needed by xrandr:

    cvt 1366 768
    

    example output:

    # 1368x768 59.88 Hz (CVT) hsync: 47.79 kHz; pclk: 85.25 MHz
    Modeline "1368x768_60.00"   85.25  1368 1440 1576 1784  768 771 781 798 -hsync +vsync
    
  2. build the xrandr command with the output of cvt:

    xrandr --newmode "1366x768" 85.25  1368 1440 1576 1784  768 771 781 798 -Hsync +Vsync
    

    please note Hsync and Vsync capitalized. I needed to do that to get things working on some systems

  3. Add a newmode in xrandr:

    xrandr --addmode VGA1 "1366x768"
    

    Replace VGA1 as needed

  4. Enable the new resolution:

    xrandr --output VGA1 --mode "1366x768"
    

protected by Community May 28 '15 at 17:31

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.