1

At work I have a laptop, windows 7, and I can remote into it. But sometimes it needs to be restarted (or gets restarted with updates) and then I can not log into it with Remote Desktop. This is confusing to me because I know we can do this for servers and Remote Desktop is a service so shouldn't it be running when someone is not logged in.

I wait long enough for it to reboot. I can confirm that it is at the login screen. I have Allow connections from computers running any version of Remote Desktop set. The sleep mode is turned off when plugged in, which it is. I have the firewall set through the Allow programs to communicate through Windows Firewall setting.

Any ideas?

If it helps: one of the other issues I have with the laptop is sometimes when I am logged in remotely, it will not connect to some network resources. I never had this problem with my desktop (windows 7) but they took that away and gave us "better" laptops

4
  • How is the laptop hooked into the network? Wire or WiFi? Feb 14 '14 at 14:49
  • Wifi... 6 more to go.
    – Mike
    Feb 14 '14 at 15:00
  • 1
    Then my guess is it's because the Wifi client isn't reconnecting until the first time a user logs in, try it with it wired. Feb 14 '14 at 15:12
  • If you add this as an answer then I can mark it correct. Taking it off wifi worked.
    – Mike
    Feb 15 '14 at 21:34
2

On the remote server, change the following registry setting via regedit:

Navigate to HKEY_LOCAL_MACHINE > System > CurrentControlSet > Control > Terminal Server. Change the value of “fDenyTSConnections” to “0″.

Then, ensure that TermServices is started automatically instead of Manual:

Navigate to Control Panel > Administrative Tools > Services and find Remote Desktop Configuration and Remote Desktop Services and Terminal Services (Depending on your version of Windows)

Ensure they're set to start Automatic. Default is Manual.

1
  • Thank you, this advice is helpful for any one who has not set the services to automatic but wasn't my specific issue.
    – Mike
    Feb 15 '14 at 21:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.